summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-05-26 17:26:14 +0000
committerOlivier Crête <tester@gentoo.org>2008-05-26 17:26:14 +0000
commit03e6954c243836825fa1997288847b9d2f5a8adb (patch)
tree1c3157e5132476b40b43f330428786276c6f9d29 /net-im/pidgin
parentFix the blocker atom to not be typoed, noticed by David Leverton (diff)
downloadgentoo-2-03e6954c243836825fa1997288847b9d2f5a8adb.tar.gz
gentoo-2-03e6954c243836825fa1997288847b9d2f5a8adb.tar.bz2
gentoo-2-03e6954c243836825fa1997288847b9d2f5a8adb.zip
Add patch for xmpp crash, from upstream, bug #223361
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-im/pidgin')
-rw-r--r--net-im/pidgin/ChangeLog6
-rw-r--r--net-im/pidgin/files/pidgin-2.4.2-jabber_crash_fix.patch10
-rw-r--r--net-im/pidgin/pidgin-2.4.2.ebuild9
3 files changed, 23 insertions, 2 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index fd9aa5f10080..7e1ed756bb63 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.53 2008/05/19 03:09:30 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.54 2008/05/26 17:26:14 tester Exp $
+
+ 26 May 2008; Olivier Crête <tester@gentoo.org>
+ +files/pidgin-2.4.2-jabber_crash_fix.patch, pidgin-2.4.2.ebuild:
+ Add patch for xmpp crash, from upstream, bug #223361
19 May 2008; Olivier Crête <tester@gentoo.org> pidgin-2.4.2.ebuild:
Add build-time dep for x11-proto/scrnsaverproto
diff --git a/net-im/pidgin/files/pidgin-2.4.2-jabber_crash_fix.patch b/net-im/pidgin/files/pidgin-2.4.2-jabber_crash_fix.patch
new file mode 100644
index 000000000000..6af9cbafdce3
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.4.2-jabber_crash_fix.patch
@@ -0,0 +1,10 @@
+--- pidgin-2.4.2/libpurple/protocols/jabber/auth.c 2008-05-06 14:04:00.000000000 +0200
++++ pidgin-2.4.3/libpurple/protocols/jabber/auth.c 2008-05-23 17:48:44.000000000 +0200
+@@ -936,6 +945,7 @@
+ _("Invalid challenge from server"));
+ }
+ g_free(js->expected_rspauth);
++ js->expected_rspauth = NULL;
+ } else {
+ /* assemble a response, and send it */
+ /* see RFC 2831 */
diff --git a/net-im/pidgin/pidgin-2.4.2.ebuild b/net-im/pidgin/pidgin-2.4.2.ebuild
index 4ad592e2f510..8f476d61cb3f 100644
--- a/net-im/pidgin/pidgin-2.4.2.ebuild
+++ b/net-im/pidgin/pidgin-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.4.2.ebuild,v 1.3 2008/05/19 03:09:30 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.4.2.ebuild,v 1.4 2008/05/26 17:26:14 tester Exp $
inherit flag-o-matic eutils toolchain-funcs multilib perl-app gnome2
@@ -122,6 +122,13 @@ pkg_setup() {
}
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/pidgin-2.4.2-jabber_crash_fix.patch"
+}
+
src_compile() {
# Stabilize things, for your own good
strip-flags