summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKathryn Kulick <gothgirl@gentoo.org>2006-10-13 14:01:23 +0000
committerKathryn Kulick <gothgirl@gentoo.org>2006-10-13 14:01:23 +0000
commit0d447718de84a23383ee77b448caa6abecdca9d5 (patch)
treed62c02a85b62533aefb5c05c4b0e851e84760284 /net-im
parent2.0.4 is here (diff)
downloadgentoo-2-0d447718de84a23383ee77b448caa6abecdca9d5.tar.gz
gentoo-2-0d447718de84a23383ee77b448caa6abecdca9d5.tar.bz2
gentoo-2-0d447718de84a23383ee77b448caa6abecdca9d5.zip
Adjusted tcl/tk use flag(s) on 1.5.0 ebuild
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog5
-rw-r--r--net-im/gaim/gaim-1.5.0.ebuild26
2 files changed, 18 insertions, 13 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 29b668be93b8..87f2e399c1f4 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.410 2006/10/13 12:23:41 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.411 2006/10/13 14:01:23 gothgirl Exp $
+
+ 13 Oct 2006; gothgirl <gothgirl@gentoo.org> gaim-1.5.0.ebuild:
+ Adjusted tcl/tk use flags in 1.5.0
13 Oct 2006; gothgirl <gothgirl@gentoo.org> -files/gaim-1.5.0-icq.patch,
-files/gaim-2.0.0_beta3-icq.patch, gaim-1.5.0.ebuild,
diff --git a/net-im/gaim/gaim-1.5.0.ebuild b/net-im/gaim/gaim-1.5.0.ebuild
index 87bc7d010071..65c60d5836ae 100644
--- a/net-im/gaim/gaim-1.5.0.ebuild
+++ b/net-im/gaim/gaim-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-1.5.0.ebuild,v 1.20 2006/10/13 12:23:41 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-1.5.0.ebuild,v 1.21 2006/10/13 14:01:23 gothgirl Exp $
inherit flag-o-matic eutils toolchain-funcs debug multilib perl-module perl-app
@@ -25,8 +25,8 @@ RDEPEND=">=x11-libs/gtk+-2.0
silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
eds? ( gnome-extra/evolution-data-server )
krb4? ( >=app-crypt/mit-krb5-1.3.6-r1 )
- tcltk? ( dev-lang/tcl
- dev-lang/tk )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
x11-libs/startup-notification"
DEPEND="$RDEPEND
@@ -100,14 +100,6 @@ src_compile() {
[ "`gcc-version`" == "3.2" ] && filter-flags -msse2
local myconf
- use debug && myconf="${myconf} --enable-debug"
- use perl || myconf="${myconf} --disable-perl"
- use spell || myconf="${myconf} --disable-gtkspell"
- use nls || myconf="${myconf} --disable-nls"
- use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
- use eds || myconf="${myconf} --disable-gevolution"
- use krb4 && myconf="${myconf} --with-krb4"
- use tcltk || myconf="${myconf} --disable-tcl --disable-tk"
if use gnutls ; then
einfo "Disabling NSS, using GnuTLS"
@@ -124,7 +116,17 @@ src_compile() {
fi
- econf ${myconf} || die "Configuration failed"
+ econf\
+ $(use_enable debug) \
+ $(use_enable perl) \
+ $(use_enable spell gtkspell) \
+ $(use_enable nls) \
+ $(use_enable nas) \
+ $(use_enable eds gevolution) \
+ $(use_enable krb4) \
+ $(use_enable tcl) \
+ $(use_enable tk) \
+ ${myconf} || die "Configuration failed"
emake -j1 || die "Make failed"
}