summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2003-06-18 20:23:42 +0000
committerRainer Groesslinger <scandium@gentoo.org>2003-06-18 20:23:42 +0000
commit4bad4a9a4cc12a9245dbc7a3982403caf053aab2 (patch)
tree7435ac5e7a04d1362c1192c808ce4d23d0037744 /net-im
parentInitial import. (diff)
downloadgentoo-2-4bad4a9a4cc12a9245dbc7a3982403caf053aab2.tar.gz
gentoo-2-4bad4a9a4cc12a9245dbc7a3982403caf053aab2.tar.bz2
gentoo-2-4bad4a9a4cc12a9245dbc7a3982403caf053aab2.zip
new version
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/ChangeLog7
-rw-r--r--net-im/psi/Manifest4
-rw-r--r--net-im/psi/files/digest-psi-0.92
-rw-r--r--net-im/psi/psi-0.9.ebuild78
4 files changed, 89 insertions, 2 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index 50891f3a60e0..9a5920cb23e6 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/psi
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.12 2003/05/21 14:08:34 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.13 2003/06/18 20:23:19 scandium Exp $
+
+*psi-0.9 (18 Jun 2003)
+
+ 18 Jun 2003; Rainer Groesslinger <scandium@gentoo.org> psi-0.9.ebuild:
+ new version, provided by Andrey Ulanov <drey@rt.mipt.ru> in bug #23003
*psi-0.8.7-r1 (21 May 2003)
diff --git a/net-im/psi/Manifest b/net-im/psi/Manifest
index 878298ff2f91..4548d273c9f4 100644
--- a/net-im/psi/Manifest
+++ b/net-im/psi/Manifest
@@ -1,6 +1,8 @@
-MD5 91149ce6f41da17eaf9b5afd3a6eeca6 ChangeLog 2125
+MD5 d2e320eb6b3fd556c157e89394d0ceeb ChangeLog 2298
MD5 ff846a08ccf1b11ef79650c3b99da985 psi-0.8.7.ebuild 1436
+MD5 654918c48d7d5cdf5063be5ae54dadac psi-0.9.ebuild 1479
MD5 fd8f74bce661a15e27e82d46e533a0bb psi-0.8.7-r1.ebuild 1548
+MD5 e4acc00d7ae1d10a2788e5db6ba73dbc files/digest-psi-0.9 119
MD5 f53c32fcb3dcafee69c54352e27202f4 files/digest-psi-0.8.7 122
MD5 83db3cef4d81d6fa30bc81db011776de files/gen2-branding-0.8.7.patch 407
MD5 896d01f56380f7fb991f3f19f4165542 files/0.8.7-shutdown.patch 375
diff --git a/net-im/psi/files/digest-psi-0.9 b/net-im/psi/files/digest-psi-0.9
new file mode 100644
index 000000000000..8b13928a5f68
--- /dev/null
+++ b/net-im/psi/files/digest-psi-0.9
@@ -0,0 +1,2 @@
+MD5 bf3aaa7fa8a1efdff9f96fa718366aa8 psi-0.9.tar.bz2 968348
+MD5 2593eb1e979070edcd07e10442f117dc qssl-2.0.tar.bz2 8317
diff --git a/net-im/psi/psi-0.9.ebuild b/net-im/psi/psi-0.9.ebuild
new file mode 100644
index 000000000000..d17e1e65a178
--- /dev/null
+++ b/net-im/psi/psi-0.9.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.9.ebuild,v 1.1 2003/06/18 20:23:19 scandium Exp $
+inherit kde-functions
+
+IUSE="ssl crypt"
+
+S=${WORKDIR}/${P}
+QV="2.0"
+SRC_URI="mirror://sourceforge/psi/${P}.tar.bz2
+ mirror://sourceforge/psi/qssl-${QV}.tar.bz2"
+DESCRIPTION="QT 3.x Jabber Client, with Licq-like interface"
+HOMEPAGE="http://psi.affinix.com"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+need-qt 3
+
+newdepend "ssl? ( >=dev-libs/openssl-0.9.6c )
+ crypt? ( >=app-crypt/gnupg-1.2.2 )"
+
+src_unpack() {
+
+ unpack ${P}.tar.bz2
+ unpack qssl-${QV}.tar.bz2
+ cd ${S}/src
+ patch -p0 < ${FILESDIR}/gen2-branding-0.8.7.patch
+}
+
+src_compile() {
+
+ ./configure --prefix=/usr || die
+ make || die
+ mv src/psi psi
+
+ if [ "`use ssl`" ]; then
+ cd ${WORKDIR}/qssl-${QV}
+ qmake qssl.pro
+ make
+ fi
+
+
+}
+
+src_install() {
+
+ export PREFIX=${D}/usr
+ export BINDIR=$PREFIX/bin
+ export LIBDIR=$PREFIX/share/psi
+
+ dodir /usr/share/psi
+ echo [Installing Psi]
+
+ mkdir -p $BINDIR
+ mkdir -p $LIBDIR
+
+ echo Copying program to $BINDIR
+ cp ./psi $BINDIR
+
+ echo Copying additional files to $LIBDIR
+ cp -r ./image $LIBDIR
+ cp -r ./iconsets $LIBDIR
+ cp -r ./sound $LIBDIR
+ cp -r ./certs $LIBDIR
+
+ dodoc README COPYING
+
+
+
+ if [ "`use ssl`" ]; then
+ cd ${WORKDIR}/qssl-${QV}
+ cp libqssl.so ${D}/usr/share/psi
+ cd ${S}
+ fi
+
+}