summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-04-23 14:18:02 +0000
committerDon Seiler <rizzo@gentoo.org>2004-04-23 14:18:02 +0000
commitb5df54f0326616b0fcdb2471b196a92de29f1ea9 (patch)
tree805a3f16fcf5146b8a061b72b124b8e12725d5b1 /net-im
parentAdded IUSE. (Manifest recommit) (diff)
downloadgentoo-2-b5df54f0326616b0fcdb2471b196a92de29f1ea9.tar.gz
gentoo-2-b5df54f0326616b0fcdb2471b196a92de29f1ea9.tar.bz2
gentoo-2-b5df54f0326616b0fcdb2471b196a92de29f1ea9.zip
Patch to fix building on gcc2. Thanks to Tristan Henderson, fixes Bug #48554
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim-encryption/ChangeLog6
-rw-r--r--net-im/gaim-encryption/files/gaim-encryption-2.24-gcc2_fix.patch23
-rw-r--r--net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild3
3 files changed, 30 insertions, 2 deletions
diff --git a/net-im/gaim-encryption/ChangeLog b/net-im/gaim-encryption/ChangeLog
index fef16539ddd9..f824e6084165 100644
--- a/net-im/gaim-encryption/ChangeLog
+++ b/net-im/gaim-encryption/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/gaim-encryption
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.21 2004/04/23 12:12:51 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.22 2004/04/23 14:18:02 rizzo Exp $
+
+ 23 Apr 2004; Don Seiler <rizzo@gentoo.org>;
+ +files/gaim-encryption-2.24-gcc2_fix.patch, gaim-encryption-2.24-r1.ebuild:
+ Patch to fix building on gcc2. Thanks to Tristan Henderson, fixes Bug #48554
*gaim-encryption-2.24-r1 (23 Apr 2004)
diff --git a/net-im/gaim-encryption/files/gaim-encryption-2.24-gcc2_fix.patch b/net-im/gaim-encryption/files/gaim-encryption-2.24-gcc2_fix.patch
new file mode 100644
index 000000000000..7af7f9b5aa0b
--- /dev/null
+++ b/net-im/gaim-encryption/files/gaim-encryption-2.24-gcc2_fix.patch
@@ -0,0 +1,23 @@
+diff -Naur gaim-encryption-2.24.orig/encrypt.c gaim-encryption-2.24/encrypt.c
+--- gaim-encryption-2.24.orig/encrypt.c 2004-04-15 23:01:18.000000000 -0400
++++ gaim-encryption-2.24/encrypt.c 2004-04-21 07:38:30.000000000 -0400
+@@ -841,6 +841,9 @@
+
+ int baggage_size;
+ char baggage[BUF_LONG];
++
++ const gchar* header = g_hash_table_lookup(header_table, (gpointer)gaim_account_get_protocol(conv->account));
++ const gchar* footer = g_hash_table_lookup(footer_table, (gpointer)gaim_account_get_protocol(conv->account));
+
+ if (msg_id == 0) {
+ gaim_debug(GAIM_DEBUG_ERROR, "gaim-encryption", "Bad call to resend_msg: %p %p\n", conv, msg_id);
+@@ -851,9 +854,6 @@
+ conv = gaim_conversation_new(GAIM_CONV_IM, acct, name);
+ }
+
+- const gchar* header = g_hash_table_lookup(header_table, (gpointer)gaim_account_get_protocol(conv->account));
+- const gchar* footer = g_hash_table_lookup(footer_table, (gpointer)gaim_account_get_protocol(conv->account));
+-
+ if (!header) header = header_default;
+ if (!footer) footer = "";
+
diff --git a/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild b/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild
index ecd1759436d0..d4ed7fd8decc 100644
--- a/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild
+++ b/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild,v 1.3 2004/04/23 12:25:23 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/gaim-encryption-2.24-r1.ebuild,v 1.4 2004/04/23 14:18:02 rizzo Exp $
inherit flag-o-matic
@@ -20,6 +20,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/encrypt_api.diff
+ epatch ${FILESDIR}/gaim-encryption-2.24-gcc2_fix.patch
}
src_compile() {