summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-08-07 12:46:34 +0000
committerAlex Legler <a3li@gentoo.org>2010-08-07 12:46:34 +0000
commitf321b1e9d67af6982ddc0047ee289c1d77f3f58e (patch)
tree940566a4f840d4b6adc8c90ef07a279c9f8afa7c /net-irc/bip
parentVersion bump, now with documentation and tests. (diff)
downloadgentoo-2-f321b1e9d67af6982ddc0047ee289c1d77f3f58e.tar.gz
gentoo-2-f321b1e9d67af6982ddc0047ee289c1d77f3f58e.tar.bz2
gentoo-2-f321b1e9d67af6982ddc0047ee289c1d77f3f58e.zip
Version bump, adding support for freenode mute lists (+q).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/bip')
-rw-r--r--net-irc/bip/ChangeLog8
-rw-r--r--net-irc/bip/bip-0.8.5.ebuild66
-rw-r--r--net-irc/bip/files/bip-freenode.patch18
-rw-r--r--net-irc/bip/metadata.xml4
4 files changed, 94 insertions, 2 deletions
diff --git a/net-irc/bip/ChangeLog b/net-irc/bip/ChangeLog
index 8b316ab060ec..e198df8ace66 100644
--- a/net-irc/bip/ChangeLog
+++ b/net-irc/bip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/bip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.13 2010/07/30 15:05:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.14 2010/08/07 12:46:33 a3li Exp $
+
+*bip-0.8.5 (07 Aug 2010)
+
+ 07 Aug 2010; Alex Legler <a3li@gentoo.org> +bip-0.8.5.ebuild,
+ +files/bip-freenode.patch, metadata.xml:
+ Version bump, adding support for freenode mute lists (+q).
30 Jul 2010; Markos Chandras <hwoarang@gentoo.org> bip-0.8.4.ebuild:
Stable on amd64 wrt bug #330121
diff --git a/net-irc/bip/bip-0.8.5.ebuild b/net-irc/bip/bip-0.8.5.ebuild
new file mode 100644
index 000000000000..2d0daf51623b
--- /dev/null
+++ b/net-irc/bip/bip-0.8.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.5.ebuild,v 1.1 2010/08/07 12:46:33 a3li Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Multiuser IRC proxy with ssl support"
+HOMEPAGE="http://bip.t1r.net/"
+SRC_URI="http://bip.t1r.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug freenode noctcp ssl vim-syntax oidentd"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ vim-syntax? ( || ( app-editors/vim
+ app-editors/gvim ) )
+ oidentd? ( >=net-misc/oidentd-2.0 )"
+
+src_prepare() {
+ if use noctcp; then
+ sed -i -e '/irc_privmsg_check_ctcp(server, line);/s:^://:' src/irc.c || die
+ fi
+
+ if use freenode; then
+ epatch "${FILESDIR}/${PN}-freenode.patch" || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with ssl openssl) \
+ $(use_enable debug) \
+ $(use_enable oidentd)
+}
+
+src_compile() {
+ # Parallel make fails.
+ # {C,CXX,LD}FLAGS aren't respected, bug 241030.
+ emake CFLAGS="${CFLAGS}" CPPFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin src/bip src/bipmkpw || die "dobin failed"
+
+ dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+ newdoc samples/bip.conf bip.conf.sample || die "newdoc failed"
+ doman bip.1 bip.conf.5 bipmkpw.1 || die "doman failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins samples/bip.vim || die "doins failed"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/bip.vim || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ elog 'Default configuration file is "~/.bip/bip.conf"'
+ elog "You can find a sample configuration file in"
+ elog "/usr/share/doc/${PF}/bip.conf.sample"
+}
diff --git a/net-irc/bip/files/bip-freenode.patch b/net-irc/bip/files/bip-freenode.patch
new file mode 100644
index 000000000000..437da08f438d
--- /dev/null
+++ b/net-irc/bip/files/bip-freenode.patch
@@ -0,0 +1,18 @@
+Freenode's ircd-seven uses a custom banlist type for mutes (+q).
+This patch makes bip handle +q the same way as +q.
+Without it, a user wouldn't get the banlist replies for mutes.
+
+diff --git a/src/irc.c b/src/irc.c
+index 556bf97..a5cc039 100644
+--- a/src/irc.c
++++ b/src/irc.c
+@@ -944,7 +947,8 @@ static int irc_cli_mode(struct link_client *ic, struct line *line)
+
+ /* This is a wild guess and that sucks. */
+ if (!irc_line_elem_equals(line, 0, "MODE") ||
+- strchr(irc_line_elem(line, 2), 'b') == NULL)
++ (strchr(irc_line_elem(line, 2), 'b') == NULL &&
++ strchr(irc_line_elem(line, 2), 'q') == NULL))
+ return OK_COPY;
+
+ ++ic->who_count;
diff --git a/net-irc/bip/metadata.xml b/net-irc/bip/metadata.xml
index 09a9076a4fa5..6a193d080ebf 100644
--- a/net-irc/bip/metadata.xml
+++ b/net-irc/bip/metadata.xml
@@ -15,9 +15,11 @@
of what was said while you were away.
</longdescription>
<use>
- <flag name="oidentd">Enable oidentd support</flag>
+ <flag name="freenode">Enables freenode-specific functionality.
+ Currently that is only support for mute lists (MODE #channel +q).</flag>
<flag name="noctcp">Disable the automatic CTCP VERSION reply which is often
exploited by malicious people to cause a DoS (reconnect due to flooding).
</flag>
+ <flag name="oidentd">Enable oidentd support</flag>
</use>
</pkgmetadata>