summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-02-20 16:54:10 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-02-20 16:54:10 +0000
commit7381b403aa0558950a518a3590efc2de5cf56fce (patch)
treeaf2a6b53774f224f1e6a607aa442d894247e9fe9 /net-irc/bitchx
parentpossible fix added (diff)
downloadgentoo-2-7381b403aa0558950a518a3590efc2de5cf56fce.tar.gz
gentoo-2-7381b403aa0558950a518a3590efc2de5cf56fce.tar.bz2
gentoo-2-7381b403aa0558950a518a3590efc2de5cf56fce.zip
Security update
Diffstat (limited to 'net-irc/bitchx')
-rw-r--r--net-irc/bitchx/ChangeLog7
-rw-r--r--net-irc/bitchx/bitchx-1.0.19-r4.ebuild139
-rw-r--r--net-irc/bitchx/files/bitchx-1.0.18-dupver.patch11
-rw-r--r--net-irc/bitchx/files/bitchx-1.0.18-r5-gentoo.diff31
-rw-r--r--net-irc/bitchx/files/bitchx-1.0.19-r4-gentoo.diff14
-rw-r--r--net-irc/bitchx/files/digest-bitchx-1.0.19-r41
6 files changed, 160 insertions, 43 deletions
diff --git a/net-irc/bitchx/ChangeLog b/net-irc/bitchx/ChangeLog
index 0529a03d5fe5..26dd3c3b916f 100644
--- a/net-irc/bitchx/ChangeLog
+++ b/net-irc/bitchx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/bitchx
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.17 2003/02/12 08:03:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.18 2003/02/20 16:54:10 aliz Exp $
+
+*bitchx-1.0.19-r4 (20 Feb 2003)
+
+ 20 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-irc/bitchx/bitchx-1.0.19-r4.ebuild b/net-irc/bitchx/bitchx-1.0.19-r4.ebuild
new file mode 100644
index 000000000000..c7f3a8dab880
--- /dev/null
+++ b/net-irc/bitchx/bitchx-1.0.19-r4.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.0.19-r4.ebuild,v 1.1 2003/02/20 16:54:10 aliz Exp $
+
+IUSE="ssl esd gnome xmms ncurses ipv6 gtk cjk"
+
+MY_P=ircii-pana-${PV/.0./.0c}
+S=${WORKDIR}/BitchX
+DESCRIPTION="An IRC Client"
+SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${MY_P}.tar.gz
+ cjk? (http://www.gentoo.org/~seo/distfiles/bitchx-1.0.19-cjk.patch)"
+HOMEPAGE="http://www.bitchx.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+inherit flag-o-matic
+replace-flags -O[3-9] -O2
+
+
+# BitchX needs to be merged with -fPIC on alpha boxes
+# This fixes bug 10932
+[ "${ARCH}" = "alpha" ] && append-flags "-fPIC"
+
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ xmms? ( media-sound/xmms )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ ncurses? ( sys-libs/ncurses )
+ esd? ( >=media-sound/esound-0.2.5
+ >=media-libs/audiofile-0.1.5 )
+ gtk? ( =x11-libs/gtk+-1.2*
+ >=media-libs/imlib-1.9.10-r1 )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${S}
+ if [ -n "`use cjk`" ]
+ then patch -p0 < ${FILESDIR}/${P}-cjk.patch
+ fi
+
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ einfo "debugging"
+ myconf="${myconf} --enable-debug"
+ fi
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use esd && use gtk \
+ && myconf="${myconf} --enable-sound" \
+ || myconf="${myconf} --disable-sound"
+
+ use gtk \
+ || myconf="${myconf} --without-gtk"
+
+ use ipv6 \
+ && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+
+ #not tested
+ #use ncurses \
+ # && myconf="${myconf} --without-tgetent" \
+ # || myconf="${myconf} --with-tgetent"
+
+ # lamer@gentoo.org BROKEN, will not work with our socks
+ # implementations, is looking for a SOCKSConnect function that our
+ # dante packages don't have :-(
+ # use socks5 \
+ # && myconf="${myconf} --with-socks=5" \
+ # || myconf="${myconf} --without-socks"
+
+ mv ${S}/include/config.h ${S}/include/config.h.orig
+ sed -e "s/#undef LATIN1/#define LATIN1 ON/;" \
+ ${S}/include/config.h.orig > \
+ ${S}/include/config.h
+
+ econf \
+ --enable-cdrom \
+ --with-plugins \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+
+ rm ${D}/usr/share/man/man1/BitchX*
+ doman doc/BitchX.1
+
+ use gnome && ( \
+ exeinto /usr/bin
+ newexe ${S}/source/BitchX BitchX-1.0c19
+ dosym gtkBitchX-1.0c19 /usr/bin/gtkBitchX
+ )
+
+ dosym BitchX-1.0c19 /usr/bin/BitchX
+
+ chmod -x ${D}/usr/lib/bx/plugins/BitchX.hints
+
+ cd ${S}
+ dodoc Changelog README* IPv6-support COPYING
+ cd doc
+ insinto /usr/X11R6/include/bitmaps
+ doins BitchX.xpm
+
+ dodoc BitchX-* BitchX.bot *.doc BitchX.faq README.hooks
+ dodoc bugs *.txt functions ideas mode tcl-ideas watch
+ dodoc *.tcl
+ dohtml *.html
+
+ docinto plugins
+ dodoc plugins
+ cd ../dll
+ insinto /usr/lib/bx/wav
+ doins wavplay/*.wav
+ cp acro/README acro/README.acro
+ dodoc acro/README.acro
+ cp arcfour/README arcfour/README.arcfour
+ dodoc arcfour/README.arcfour
+ cp blowfish/README blowfish/README.blowfish
+ dodoc blowfish/README.blowfish
+ dodoc nap/README.nap
+ cp qbx/README qbx/README.qbx
+ dodoc qbx/README.qbx
+}
diff --git a/net-irc/bitchx/files/bitchx-1.0.18-dupver.patch b/net-irc/bitchx/files/bitchx-1.0.18-dupver.patch
deleted file mode 100644
index fb8847138c13..000000000000
--- a/net-irc/bitchx/files/bitchx-1.0.18-dupver.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urNd BitchX/source/modules.c BitchX/source/modules.c.new
---- BitchX/source/modules.c Thu Apr 4 20:08:15 2002
-+++ BitchX/source/modules.c.new Thu Apr 4 20:08:27 2002
-@@ -65,7 +65,6 @@
-
- Function_ptr global_table[NUMBER_OF_GLOBAL_FUNCTIONS] = { NULL };
- extern int read_sockets();
--extern unsigned long bitchx_numver;
- extern int identd;
-
- extern int (*dcc_open_func) (int, int, unsigned long, int);
diff --git a/net-irc/bitchx/files/bitchx-1.0.18-r5-gentoo.diff b/net-irc/bitchx/files/bitchx-1.0.18-r5-gentoo.diff
deleted file mode 100644
index 034b395952d9..000000000000
--- a/net-irc/bitchx/files/bitchx-1.0.18-r5-gentoo.diff
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -ur BitchX.orig/configure BitchX/configure
---- BitchX.orig/configure Mon Jan 8 01:24:22 2001
-+++ BitchX/configure Tue Apr 17 18:33:57 2001
-@@ -7030,7 +7030,8 @@
-
- echo "$as_me:7031: checking for ZVT" >&5
- echo $ECHO_N "checking for ZVT... $ECHO_C" >&6
-- ZVT_LIBS="`$GNOME_CONFIG $gnome_config_args --libs-only-l zvt`"
-+ ZVT_CFLAGS="`$GNOME_CONFIG $gnome_config_args --cflags gnome`"
-+ ZVT_LIBS="`$GNOME_CONFIG $gnome_config_args --libs zvt`"
- if test x"$ZVT_LIBS" != x""; then
- echo "$as_me:7035: result: yes" >&5
- echo "${ECHO_T}yes" >&6
-@@ -7097,8 +7098,6 @@
- G_CFLAGS="$GLIB_CFLAGS $GTK_CFLAGS $GDK_IMLIB_CFLAGS $ZVT_CFLAGS"
- G_LIBS="$GLIB_LIBS $GTK_LIBS $PTHREAD_LIBS $GDK_IMLIB_LIBS $ZVT_LIBS"
- fi
-- CFLAGS="$CFLAGS $G_CFLAGS"
-- LIBS="$G_LIBS $LIBS"
- VERSION="gtk$VERSION"
- _VERSION_="gtk$_VERSION_"
-
-@@ -11944,6 +11943,8 @@
- SHLIB_SUFFIX=".so"
- fi
-
-+CFLAGS="$CFLAGS $G_CFLAGS"
-+LIBS="$G_LIBS $LIBS"
- if test x"$GCC" = x"yes" -a -z "`echo "$CFLAGS" | grep \\\-Wall`"; then
- CFLAGS="$CFLAGS -Wall"
- fi
diff --git a/net-irc/bitchx/files/bitchx-1.0.19-r4-gentoo.diff b/net-irc/bitchx/files/bitchx-1.0.19-r4-gentoo.diff
new file mode 100644
index 000000000000..fa7eb1217ad0
--- /dev/null
+++ b/net-irc/bitchx/files/bitchx-1.0.19-r4-gentoo.diff
@@ -0,0 +1,14 @@
+--- source/funny.c 2003-02-20 16:37:07.000000000 +0000
++++ source/funny.c 2003-02-20 16:39:13.000000000 +0000
+@@ -261,6 +261,11 @@
+ channel = Args[1];
+ line = Args[2];
+
++ if (channel == NULL || line == NULL) {
++ bitchsay("Invalid number of arguments for %s", __FUNCTION__);
++ return;
++ }
++
+ ptr = line;
+ while (*ptr)
+ {
diff --git a/net-irc/bitchx/files/digest-bitchx-1.0.19-r4 b/net-irc/bitchx/files/digest-bitchx-1.0.19-r4
new file mode 100644
index 000000000000..733d621134c6
--- /dev/null
+++ b/net-irc/bitchx/files/digest-bitchx-1.0.19-r4
@@ -0,0 +1 @@
+MD5 79431ff0880e7317049045981fac8adc ircii-pana-1.0c19.tar.gz 2533621