summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2003-11-14 02:55:19 +0000
committerChuck Short <zul@gentoo.org>2003-11-14 02:55:19 +0000
commitb8ca60ea6bc9dd9ae25baefca27eb47b2c013e35 (patch)
treebdacff72c40cd7566560744fb4604764571be581 /net-irc/epic4
parentEbuild clean ups. (diff)
downloadgentoo-2-b8ca60ea6bc9dd9ae25baefca27eb47b2c013e35.tar.gz
gentoo-2-b8ca60ea6bc9dd9ae25baefca27eb47b2c013e35.tar.bz2
gentoo-2-b8ca60ea6bc9dd9ae25baefca27eb47b2c013e35.zip
Ebuild clean ups.
Diffstat (limited to 'net-irc/epic4')
-rw-r--r--net-irc/epic4/Manifest2
-rw-r--r--net-irc/epic4/epic4-1.1.14-r1.ebuild72
-rw-r--r--net-irc/epic4/files/digest-epic4-1.1.14-r12
3 files changed, 75 insertions, 1 deletions
diff --git a/net-irc/epic4/Manifest b/net-irc/epic4/Manifest
index 042e05f23416..5b0cd114564b 100644
--- a/net-irc/epic4/Manifest
+++ b/net-irc/epic4/Manifest
@@ -1,4 +1,4 @@
-MD5 b105d132380aea72ed6f1763e17b28b5 epic4-1.1.14-r1.ebuild 1974
+MD5 0257d9b4666ccec4ba7a6d1bc2e60b04 epic4-1.1.14-r1.ebuild 1974
MD5 c2880c7eaedef26a5d1518ecf38fba84 epic4-1.1.10.ebuild 2079
MD5 012746f52e0a8a1b41117246bbaf29f6 epic4-1.1.12.ebuild 2201
MD5 00cbb951ea73e3176a7dd612bfddcf2f epic4-1.1.14.ebuild 2055
diff --git a/net-irc/epic4/epic4-1.1.14-r1.ebuild b/net-irc/epic4/epic4-1.1.14-r1.ebuild
new file mode 100644
index 000000000000..51a62a38ea4e
--- /dev/null
+++ b/net-irc/epic4/epic4-1.1.14-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-1.1.14-r1.ebuild,v 1.1 2003/11/14 02:55:03 zul Exp $
+
+IUSE="ipv6 perl ssl tcltk"
+
+DESCRIPTION="Epic4 IRC Client"
+SRC_URI="ftp://prbh.org/pub/epic/EPIC4-ALPHA/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-20030114.tar.gz"
+HOMEPAGE="http://epicsol.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~ia64 ~alpha ~hppa"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ tcltk? ( dev-lang/tcl )"
+
+inherit flag-o-matic
+replace-flags "-O?" "-O"
+
+src_compile() {
+ myconf=""
+
+ myconf="${myconf} `use_with ipv6`"
+ myconf="${myconf} `use_with perl`"
+ myconf="${myconf} `use_with ssl`"
+ myconf="${myconf} `use_with tcltk`"
+
+ econf \
+ --libexecdir=/usr/lib/misc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die
+
+ rm -f ${D}/usr/bin/epic
+ dosym epic-EPIC4-${PV} /usr/bin/epic
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+ docinto doc
+ cd doc
+ dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
+ dodoc nicknames outputhelp server_groups SILLINESS TS4
+
+ dodir /usr/share/epic
+ tar zxvf ${DISTDIR}/epic4-help-20030114.tar.gz -C ${D}/usr/share/epic
+
+ rm -f ${D}/usr/share/epic/help/Makefile
+ rm -rf ${D}/usr/share/epic/help/CVS
+
+ chown -R root.root ${D}/usr/share/epic/help
+}
+
+pkg_postinst() {
+ einfo "If /usr/share/epic/script/local does not exist, I will now"
+ einfo "create it. If you do not like the look/feel of this file, or"
+ einfo "if you'd prefer to use your own script, simply remove this"
+ einfo "file. If you want to prevent this file from being installed"
+ einfo "in the future, simply create an empty file with this name."
+
+ if [ ! -e /usr/share/epic/script/local ]; then
+ cp ${FILESDIR}/local /usr/share/epic/script/
+ fi
+}
diff --git a/net-irc/epic4/files/digest-epic4-1.1.14-r1 b/net-irc/epic4/files/digest-epic4-1.1.14-r1
new file mode 100644
index 000000000000..782fa69b5800
--- /dev/null
+++ b/net-irc/epic4/files/digest-epic4-1.1.14-r1
@@ -0,0 +1,2 @@
+MD5 b041aeb0490fd542cd68dacb6f05c425 epic4-1.1.14.tar.bz2 607595
+MD5 f4220b4cf989e320fbbd6051c5117307 epic4-help-20030114.tar.gz 287157