summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-07-08 22:13:53 +0000
committerSven Wegener <swegener@gentoo.org>2004-07-08 22:13:53 +0000
commita4f5467f42b46bd6d8ac09af9eac6dc61e15e1ea (patch)
tree2c631d3f7a11601440f86b57f458843da615ce10 /net-irc/ninja/ninja-1.5.9_pre12.ebuild
parentUpdated SRC_URI. (Manifest recommit) (diff)
downloadgentoo-2-a4f5467f42b46bd6d8ac09af9eac6dc61e15e1ea.tar.gz
gentoo-2-a4f5467f42b46bd6d8ac09af9eac6dc61e15e1ea.tar.bz2
gentoo-2-a4f5467f42b46bd6d8ac09af9eac6dc61e15e1ea.zip
Updated SRC_URI and version bump.
Diffstat (limited to 'net-irc/ninja/ninja-1.5.9_pre12.ebuild')
-rw-r--r--net-irc/ninja/ninja-1.5.9_pre12.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-irc/ninja/ninja-1.5.9_pre12.ebuild b/net-irc/ninja/ninja-1.5.9_pre12.ebuild
new file mode 100644
index 000000000000..322017d3b85b
--- /dev/null
+++ b/net-irc/ninja/ninja-1.5.9_pre12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ninja-1.5.9_pre12.ebuild,v 1.1 2004/07/08 22:13:53 swegener Exp $
+
+S=${WORKDIR}/${P/_*/}
+DESCRIPTION="Ninja IRC Client"
+HOMEPAGE="http://ninja.qoop.org/"
+SRC_URI="ftp://qoop.org/ninja/stable/${P/_/}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+IUSE="ncurses ipv6 ssl"
+DEPEND="virtual/libc
+ ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ econf $(use_enable ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}