summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-24 19:08:38 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-24 19:08:38 +0000
commit1796a43e2e5ff2c60d2e1e207135e2db4d5afbec (patch)
tree20bd08e02657d4301da6f9a4f1d650de7cc01bfd /net-irc/smuxi/smuxi-0.7.2.1.ebuild
parentx86 stable wrt bug #329675 (diff)
downloadgentoo-2-1796a43e2e5ff2c60d2e1e207135e2db4d5afbec.tar.gz
gentoo-2-1796a43e2e5ff2c60d2e1e207135e2db4d5afbec.tar.bz2
gentoo-2-1796a43e2e5ff2c60d2e1e207135e2db4d5afbec.zip
Version bump with lots of bugfixes and some new features. Remove old.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/smuxi/smuxi-0.7.2.1.ebuild')
-rw-r--r--net-irc/smuxi/smuxi-0.7.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-irc/smuxi/smuxi-0.7.2.1.ebuild b/net-irc/smuxi/smuxi-0.7.2.1.ebuild
new file mode 100644
index 000000000000..516c2cd0b064
--- /dev/null
+++ b/net-irc/smuxi/smuxi-0.7.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/smuxi-0.7.2.1.ebuild,v 1.1 2010/07/24 19:08:37 pacho Exp $
+
+EAPI=2
+
+inherit base mono eutils
+
+DESCRIPTION="A flexible, irssi-like and user-friendly IRC client for the Gnome Desktop."
+HOMEPAGE="http://www.smuxi.org/page/Download"
+SRC_URI="http://smuxi.meebey.net/jaws/data/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=dev-dotnet/smartirc4net-0.4.5.1
+ >=dev-dotnet/nini-1.1.0-r2
+ >=dev-dotnet/log4net-1.2.10-r2
+ gnome? ( >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/gconf-sharp-2.12
+ >=dev-dotnet/glade-sharp-2.12
+ >=dev-dotnet/glib-sharp-2.12 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.25
+ >=sys-devel/gettext-0.17
+ >=dev-util/pkgconfig-0.23"
+
+src_configure() {
+ econf --disable-dependency-tracking \
+ --enable-engine-irc \
+ $(use_enable gnome frontend-gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc FEATURES TODO README || die "dodoc failed"
+}