summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-07-31 12:32:33 +0000
committerSven Wegener <swegener@gentoo.org>2004-07-31 12:32:33 +0000
commit962f749addcc73b80b95982dd44ad7f32268009a (patch)
treea0ca67b3fed4376d2fb618fc0216f9c3c61defb6 /net-irc/xchat/xchat-2.0.10-r3.ebuild
parentAdded app-emulation/emul-linux-x86-glibc (diff)
downloadgentoo-2-962f749addcc73b80b95982dd44ad7f32268009a.tar.gz
gentoo-2-962f749addcc73b80b95982dd44ad7f32268009a.tar.bz2
gentoo-2-962f749addcc73b80b95982dd44ad7f32268009a.zip
Another revision bump for an updated tab completion patch. This should close bug #58666 (Tab completion is quirky in XChat) by David Lloyd <dmlloyd@tds.net>. Added backported patch from upstream CVS which fixes bug #56324 (xchat 2.0.10 cjk preedit string bug) by Jung Tae-young <master@mytears.org>.
Diffstat (limited to 'net-irc/xchat/xchat-2.0.10-r3.ebuild')
-rw-r--r--net-irc/xchat/xchat-2.0.10-r3.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/net-irc/xchat/xchat-2.0.10-r3.ebuild b/net-irc/xchat/xchat-2.0.10-r3.ebuild
new file mode 100644
index 000000000000..fd1bec0cf5a8
--- /dev/null
+++ b/net-irc/xchat/xchat-2.0.10-r3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.10-r3.ebuild,v 1.1 2004/07/31 12:32:33 swegener Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/2.0/${P}.tar.bz2
+ xchatdccserver? ( http://dfx.at/xchat/xchat-dccserver-0.4.patch )"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~sparc ~hppa ~ppc ~alpha ~amd64 ~ia64 ~mips ppc64"
+IUSE="perl tcltk python ssl mmx ipv6 nls"
+# Local use flag for the text frontend (bug #26427)
+IUSE="${IUSE} xchattext xchatnogtk xchatdccserver"
+
+# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+if [ ${ARCH} = "sparc" ]
+then
+ replace-flags "-O3" "-O2"
+fi
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ >=sys-apps/sed-4
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/xc2010-fixtabcomp3.diff
+ epatch ${FILESDIR}/xc2010-fixfocus.diff
+ epatch ${FILESDIR}/${PV}-preeditstring.patch
+ use xchatdccserver && epatch ${DISTDIR}/xchat-dccserver-0.4.patch
+}
+
+src_compile() {
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ # test for local usage of xchatnogtk
+ local gtkconf
+ use xchatnogtk \
+ && gtkconf="--disable-gtkfe" \
+ || gtkconf="--enable-gtkfe"
+
+ econf \
+ ${gtkconf} \
+ `use_enable ssl openssl` \
+ `use_enable perl` \
+ `use_enable python` \
+ `use_enable tcltk tcl` \
+ `use_enable mmx` \
+ `use_enable ipv6` \
+ `use_enable nls` \
+ `use_enable xchattext textfe` \
+ --program-suffix=-2 \
+ || die "Configure failed"
+
+ emake || die "Compile failed"
+
+}
+
+src_install() {
+
+ # some magic to create a menu entry for xchat 2
+ sed -i \
+ -e "s:^Exec=xchat$:Exec=xchat-2:" \
+ -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
+ xchat.desktop
+
+ make DESTDIR=${D} install || die "Install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h
+
+ dodoc ChangeLog README*
+
+}
+
+pkg_postinst() {
+ einfo
+ einfo "With this release the tab completion behaviour has changed."
+ einfo "See http://forum.xchat.org/viewtopic.php?p=653 for more info."
+ einfo "Use '/set completion_amount 0' to revert back to the old behaviour."
+ einfo
+}