summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-02 13:29:10 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-02 13:29:10 +0000
commit84c191b6886bc7a137de1e385333330ed35ac894 (patch)
treecddc66b3b14ecf3d3249f5ca07d5994aa8f10616 /net-irc/xchat
parentia64 stable wrt bug 115242 (diff)
downloadgentoo-2-84c191b6886bc7a137de1e385333330ed35ac894.tar.gz
gentoo-2-84c191b6886bc7a137de1e385333330ed35ac894.tar.bz2
gentoo-2-84c191b6886bc7a137de1e385333330ed35ac894.zip
Version bump wrt bug 173105
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/digest-xchat-2.8.26
-rw-r--r--net-irc/xchat/xchat-2.8.2.ebuild97
3 files changed, 109 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 5f23786e6b11..d00c8a9a671c 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.233 2007/03/27 19:16:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.234 2007/04/02 13:29:10 armin76 Exp $
+
+*xchat-2.8.2 (02 Apr 2007)
+
+ 02 Apr 2007; Raúl Porcel <armin76@gentoo.org> +xchat-2.8.2.ebuild:
+ Version bump wrt bug 173105
27 Mar 2007; Raúl Porcel <armin76@gentoo.org> xchat-2.8.0.ebuild:
ia64 stable wrt bug 167328
diff --git a/net-irc/xchat/files/digest-xchat-2.8.2 b/net-irc/xchat/files/digest-xchat-2.8.2
new file mode 100644
index 000000000000..78769b5d086e
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.8.2
@@ -0,0 +1,6 @@
+MD5 d87a93bcd39d96ff3a3d0f8199efcf12 xchat-2.8.2.tar.bz2 1331148
+RMD160 62f9ffeb77243e1c20d81f0543ea8ccc7d3cd225 xchat-2.8.2.tar.bz2 1331148
+SHA256 9f6c22e7116afea4c00d90346b0522069f1c2197e8d0ad2f1545da01329750fe xchat-2.8.2.tar.bz2 1331148
+MD5 c0220456a4df8ee54ae02e7704a6e024 xchat-dccserver-0.6.patch.bz2 49320
+RMD160 24cc9bd414b1dd0e7e38ba9a49d12257aeb89e68 xchat-dccserver-0.6.patch.bz2 49320
+SHA256 90a49a8d810380020c507c1a36f02e7d972cf92b5e4802dcd5cc518cba29078f xchat-dccserver-0.6.patch.bz2 49320
diff --git a/net-irc/xchat/xchat-2.8.2.ebuild b/net-irc/xchat/xchat-2.8.2.ebuild
new file mode 100644
index 000000000000..6ff5f7289487
--- /dev/null
+++ b/net-irc/xchat/xchat-2.8.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.2.ebuild,v 1.1 2007/04/02 13:29:10 armin76 Exp $
+
+inherit eutils versionator gnome2
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ xchatdccserver? ( mirror://gentoo/${PN}-dccserver-0.6.patch.bz2 )"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="perl dbus tcl python ssl mmx ipv6 nls spell xchattext xchatnogtk xchatdccserver"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ !xchatnogtk? ( >=x11-libs/gtk+-2.10.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( >=dev-lang/python-2.2 )
+ tcl? ( dev-lang/tcl )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.35 ) ) )
+ spell? ( app-text/enchant )
+ !<net-irc/xchat-gnome-0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
+
+ epatch "${FILESDIR}"/xc280-fix-back.diff
+ epatch "${FILESDIR}"/xc280-fix-ja.diff
+
+ # use libdir/xchat/plugins as the plugin directory
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
+ "${S}"/configure{,.in} || die
+ fi
+}
+
+src_compile() {
+ # Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+ if [[ ${ARCH} = sparc ]] ; then
+ replace-flags "-O[3-9]" "-O2"
+ fi
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ --enable-shm \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable spell spell static) \
+ $(use_enable xchattext textfe) \
+ $(use_enable !xchatnogtk gtkfe) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ USE_DESTDIR=1 gnome2_src_install || die "make install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "XChat binary has been renamed from xchat-2 to xchat."
+ elog
+
+ if has_version net-irc/xchat-systray
+ then
+ elog "XChat now includes it's own systray icon, you may want to remove net-irc/xchat-systray."
+ elog
+ fi
+}