summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-07-21 00:58:57 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-07-21 00:58:57 +0000
commite6a00acd0e333569081cb871b7c3ecbd9f315fe0 (patch)
tree586fbf5d90141eeca3d2c8f468533482c9d43a57 /net-irc/xchat
parentmasked fritzcapi drivers, take 2 (diff)
downloadgentoo-2-e6a00acd0e333569081cb871b7c3ecbd9f315fe0.tar.gz
gentoo-2-e6a00acd0e333569081cb871b7c3ecbd9f315fe0.tar.bz2
gentoo-2-e6a00acd0e333569081cb871b7c3ecbd9f315fe0.zip
Added a patch to make the input box a bit smaller.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/xchat-input-box3.patch38
-rw-r--r--net-irc/xchat/xchat-2.8.8.ebuild3
3 files changed, 46 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 37ae1093289d..b54f1a088ab3 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.280 2010/06/01 08:13:55 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.281 2010/07/21 00:58:57 polynomial-c Exp $
+
+ 21 Jul 2010; Lars Wendler <polynomial-c@gentoo.org>
+ +files/xchat-input-box3.patch, xchat-2.8.8.ebuild:
+ Added a patch to make the input box a bit smaller. Thanks to s0ulslack for
+ reporting this in bug #301161 and to Rafał Mużyło for the patch.
*xchat-2.8.8 (01 Jun 2010)
diff --git a/net-irc/xchat/files/xchat-input-box3.patch b/net-irc/xchat/files/xchat-input-box3.patch
new file mode 100644
index 000000000000..7055c7be7b73
--- /dev/null
+++ b/net-irc/xchat/files/xchat-input-box3.patch
@@ -0,0 +1,38 @@
+--- src/fe-gtk/maingui.c.old 2010-05-16 05:15:55.000000000 +0200
++++ src/fe-gtk/maingui.c 2010-07-20 23:49:11.000000000 +0200
+@@ -2828,13 +2828,13 @@
+ static void
+ mg_create_entry (session *sess, GtkWidget *box)
+ {
+- GtkWidget *sw, *hbox, *but, *entry;
++ GtkWidget *sw, *hbox, *but, *entry, *mybox;
+ session_gui *gui = sess->gui;
+
+ hbox = gtk_hbox_new (FALSE, 0);
+ gtk_box_pack_start (GTK_BOX (box), hbox, 0, 0, 0);
+
+- gui->nick_box = gtk_hbox_new (FALSE, 0);
++ gui->nick_box = gtk_vbox_new (FALSE, 0);
+ gtk_box_pack_start (GTK_BOX (hbox), gui->nick_box, 0, 0, 0);
+
+ gui->nick_label = but = gtk_button_new_with_label (sess->server->nick);
+@@ -2846,7 +2846,7 @@
+
+ #ifdef USE_GTKSPELL
+ gui->input_box = entry = gtk_text_view_new ();
+- gtk_widget_set_size_request (entry, 0, 1);
++ gtk_widget_set_size_request (entry, 0, -1);
+ gtk_text_view_set_wrap_mode (GTK_TEXT_VIEW (entry), GTK_WRAP_NONE);
+ gtk_text_view_set_accepts_tab (GTK_TEXT_VIEW (entry), FALSE);
+ if (prefs.gui_input_spell)
+@@ -2859,7 +2859,9 @@
+ GTK_POLICY_NEVER,
+ GTK_POLICY_NEVER);
+ gtk_container_add (GTK_CONTAINER (sw), entry);
+- gtk_container_add (GTK_CONTAINER (hbox), sw);
++ mybox = gtk_vbox_new(FALSE, 0);
++ gtk_box_pack_start (GTK_BOX (mybox), sw, 1, 0, 0);
++ gtk_box_pack_start (GTK_BOX (hbox), mybox, 1, 1, 0);
+ #else
+ #ifdef USE_LIBSEXY
+ gui->input_box = entry = sexy_spell_entry_new ();
diff --git a/net-irc/xchat/xchat-2.8.8.ebuild b/net-irc/xchat/xchat-2.8.8.ebuild
index 82c7cff0a8e8..20a51c5ac0ea 100644
--- a/net-irc/xchat/xchat-2.8.8.ebuild
+++ b/net-irc/xchat/xchat-2.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8.ebuild,v 1.1 2010/06/01 08:13:55 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8.ebuild,v 1.2 2010/07/21 00:58:57 polynomial-c Exp $
EAPI=2
@@ -41,6 +41,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-input-box3.patch
use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
# use libdir/xchat/plugins as the plugin directory