summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-12-19 13:07:55 +0000
committerDan Armak <danarmak@gentoo.org>2002-12-19 13:07:55 +0000
commit62f00bd9a78d901f90d36eccf9742c9faf95eb88 (patch)
tree47864f00088975b5211df5f63440811d84d193d6 /net-irc
parentmask cvs snapshot of kvirc (diff)
downloadgentoo-2-62f00bd9a78d901f90d36eccf9742c9faf95eb88.tar.gz
gentoo-2-62f00bd9a78d901f90d36eccf9742c9faf95eb88.tar.bz2
gentoo-2-62f00bd9a78d901f90d36eccf9742c9faf95eb88.zip
a cvs snapshot, hope it'll fix #7131.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/kvirc/ChangeLog10
-rw-r--r--net-irc/kvirc/files/digest-kvirc-3.0.0_pre200212171
-rw-r--r--net-irc/kvirc/kvirc-3.0.0_pre20021217.ebuild71
3 files changed, 80 insertions, 2 deletions
diff --git a/net-irc/kvirc/ChangeLog b/net-irc/kvirc/ChangeLog
index 9540403711e0..4852a4730345 100644
--- a/net-irc/kvirc/ChangeLog
+++ b/net-irc/kvirc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/kvirc
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.3 2002/07/27 13:55:29 danarmak Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.4 2002/12/19 13:07:55 danarmak Exp $
+
+*kvirc-3.0.0_pre20021217 (19 Dec 2002)
+
+ 19 Dec 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ A cvs snapshot, maksed for now. I hope it will fix bug #7131.
28 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
diff --git a/net-irc/kvirc/files/digest-kvirc-3.0.0_pre20021217 b/net-irc/kvirc/files/digest-kvirc-3.0.0_pre20021217
new file mode 100644
index 000000000000..9b3a3e8072f4
--- /dev/null
+++ b/net-irc/kvirc/files/digest-kvirc-3.0.0_pre20021217
@@ -0,0 +1 @@
+MD5 dd24cf1e78ae03563964f30c604f41fd kvirc-20021217.tar.bz2 2118984
diff --git a/net-irc/kvirc/kvirc-3.0.0_pre20021217.ebuild b/net-irc/kvirc/kvirc-3.0.0_pre20021217.ebuild
new file mode 100644
index 000000000000..c0eff69cb72d
--- /dev/null
+++ b/net-irc/kvirc/kvirc-3.0.0_pre20021217.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.0.0_pre20021217.ebuild,v 1.1 2002/12/19 13:07:55 danarmak Exp $
+IUSE="kde esd ipv6 ssl"
+inherit kde-base
+
+#MYP=${P//_/-}
+#MYPV=${PV//_/-}
+S=${WORKDIR}/kvirc3.cvs
+DESCRIPTION="An advanced IRC Client"
+SRC_URI="http://cvs.gentoo.org/~danarmak/kvirc-20021217.tar.bz2"
+HOMEPAGE="http://www.kvirc.net"
+
+SLOT="3"
+LICENSE="kvirc"
+KEYWORDS="x86"
+
+use kde && need-kde 3 || need-qt 3
+
+newdepend "esd? ( media-sound/esound )
+ ssl? ( dev-libs/openssl )"
+# oss ? ( media-libs/audiofile )"
+use kde || newdepend "arts? ( kde-base/arts )"
+
+[ -n "$DEBUG" ] && myconf="$myconf --with-debug-symbols"
+[ "$ARCH" == "x86" ] && myconf="$myconf --with-ix86-asm"
+use ipv6 && myconf="$myconf --with-ipv6-support" \
+ || myconf="$myconf --without-ipv6-support"
+# arts support without kde support isn't liked by the configure script
+# possibly it could be made to work but i didn't want to spend time on it
+use kde && myconf="$myconf --with-kde-support --with-arts-support" \
+ || myconf="$myconf --without-kde-support --without-arts-support"
+use esd && myconf="$myconf --with-esd-support" \
+ || myconf="$myconf --without-esd-support"
+#use oss && myconf="$myconf --with-audiofile--support" \
+# || myconf="$myconf --without-audiofile-support"
+use ssl && myconf="$myconf --with-ssl-support" \
+ || myconf="$myconf --without-ssl-support"
+
+# use aa even when kde support is disabled; enable local 8bit character set conversion
+myconf="$myconf --with-aa-fonts" #--with-local-8bit"
+
+src_compile() {
+
+ use kde && kde_src_compile myconf
+
+ # always install into /usr regardless of kde support
+ # kvirc doesn't have a kde-like installed file structure anyway
+ myconf="$myconf --prefix=/usr -v"
+
+ # make sure we disable kde support as the configure script can auto-enable
+ # it when it isn't wanted
+ use kde || export KDEDIR=""
+
+ need-automake 1.5
+ need-autoconf 2.5
+ ./autogen.sh
+ kde_src_compile configure make
+
+}
+
+src_install () {
+
+ make install DESTDIR=${D} || die
+ make docs DESTDIR=${D} || die
+
+ dodoc ChangeLog INSTALL README TODO
+
+}
+
+