summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2007-10-30 21:02:32 +0000
committerDawid Węgliński <cla@gentoo.org>2007-10-30 21:02:32 +0000
commitdbb164093879ffaa29d122501fd62b9b5e078235 (patch)
treed8daf5b5f239014f111a169aa02c30c830a14776 /net-irc
parentLinux 2.6.24-rc1-r7. (diff)
downloadgentoo-2-dbb164093879ffaa29d122501fd62b9b5e078235.tar.gz
gentoo-2-dbb164093879ffaa29d122501fd62b9b5e078235.tar.bz2
gentoo-2-dbb164093879ffaa29d122501fd62b9b5e078235.zip
New dependency and fixing make install stuff
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/mistbot/ChangeLog5
-rw-r--r--net-irc/mistbot/mistbot-0.9.ebuild17
2 files changed, 14 insertions, 8 deletions
diff --git a/net-irc/mistbot/ChangeLog b/net-irc/mistbot/ChangeLog
index bb4b803e773b..15c6ec3c7314 100644
--- a/net-irc/mistbot/ChangeLog
+++ b/net-irc/mistbot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/mistbot
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/mistbot/ChangeLog,v 1.1 2007/10/29 22:45:09 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/mistbot/ChangeLog,v 1.2 2007/10/30 21:02:32 cla Exp $
+
+ 30 Oct 2007; Dawid Węgliński <cla@gentoo.org> mistbot-0.9.ebuild:
+ New dependency and fixing make install stuff
*mistbot-0.9 (29 Oct 2007)
diff --git a/net-irc/mistbot/mistbot-0.9.ebuild b/net-irc/mistbot/mistbot-0.9.ebuild
index f5ad1d7a262e..fdef4a9ecba3 100644
--- a/net-irc/mistbot/mistbot-0.9.ebuild
+++ b/net-irc/mistbot/mistbot-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/mistbot/mistbot-0.9.ebuild,v 1.1 2007/10/29 22:45:09 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/mistbot/mistbot-0.9.ebuild,v 1.2 2007/10/30 21:02:32 cla Exp $
inherit eutils toolchain-funcs
@@ -20,7 +20,8 @@ RDEPEND="virtual/libc
xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen
+ app-text/xmlto )"
src_compile() {
ebegin "Change build.conf to fit needs"
@@ -30,15 +31,15 @@ src_compile() {
fi
if ! use nls; then
- sed -e '/^NLS = nls$/d' -i build.conf || die "sed failed"
+ sed -e '/^NLS\ =\nls$/d' -i build.conf || die "sed failed"
fi
if ! use debug; then
- sed -e '/^DEBUG = debug$/d' -i build.conf || die "sed failed"
+ sed -e '/^DEBUG\ =\ debug$/d' -i build.conf || die "sed failed"
fi
if ! use ssl; then
- sed -e '/^SSL = ssl$/d' -i build.conf || die "sed failed"
+ sed -e '/^SSL\ =\ ssl$/d' -i build.conf || die "sed failed"
fi
sed -e 's/^#ONCE\ =\ yes$/ONCE\ =\ yes/' -i build.conf || die "sed failed"
@@ -53,12 +54,14 @@ src_compile() {
if use doc; then
ebegin "generate documentation"
- make doc || die "make doc failed"
+ #make doc || die "make doc failed"
+ emake doc || die "make doc failed"
fi
}
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
+ #make install DESTDIR="${D}" || die "make install failed"
+ emake DESTDIR="${D}" install
dodoc AUTHORS mistbot.conf
if use doc; then