summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-27 17:52:55 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-27 17:52:55 +0000
commita382c029d5b6e41bf00857a47c7683d7615b4ad2 (patch)
treec0b03d0bb3e87bce59c895b663867d0774b6b42a /net-libs/ccrtp/ccrtp-1.7.0.ebuild
parentBump shiny new KDE 4.2.0 (diff)
downloadgentoo-2-a382c029d5b6e41bf00857a47c7683d7615b4ad2.tar.gz
gentoo-2-a382c029d5b6e41bf00857a47c7683d7615b4ad2.tar.bz2
gentoo-2-a382c029d5b6e41bf00857a47c7683d7615b4ad2.zip
version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'net-libs/ccrtp/ccrtp-1.7.0.ebuild')
-rw-r--r--net-libs/ccrtp/ccrtp-1.7.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/ccrtp/ccrtp-1.7.0.ebuild b/net-libs/ccrtp/ccrtp-1.7.0.ebuild
new file mode 100644
index 000000000000..b477a27abab2
--- /dev/null
+++ b/net-libs/ccrtp/ccrtp-1.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ccrtp-1.7.0.ebuild,v 1.1 2009/01/27 17:52:55 dragonheart Exp $
+
+inherit multilib
+
+DESCRIPTION="GNU ccRTP is an implementation of RTP, the real-time transport protocol from the IETF"
+HOMEPAGE="http://www.gnu.org/software/ccrtp/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="doc"
+SLOT="0"
+
+RDEPEND=">=dev-cpp/commoncpp2-1.3.0
+ dev-libs/libgcrypt"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ doc? ( app-doc/doxygen )"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README ChangeLog AUTHORS NEWS TODO
+ use doc && dohtml -r doc/html/*
+}
+
+pkg_postinst() {
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
+ fi
+}