summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-05-25 23:39:12 +0000
committerRémi Cardona <remi@gentoo.org>2008-05-25 23:39:12 +0000
commitbece9ee4b275c81dec8a3c49f372100d96bc6c49 (patch)
tree77709cf6e394cb092febe153801f1457aa04e50a /net-libs/gtk-vnc
parentbump to 1.8.3. Bug fixes. (diff)
downloadgentoo-2-bece9ee4b275c81dec8a3c49f372100d96bc6c49.tar.gz
gentoo-2-bece9ee4b275c81dec8a3c49f372100d96bc6c49.tar.bz2
gentoo-2-bece9ee4b275c81dec8a3c49f372100d96bc6c49.zip
net-libs/gtk-vnc: bump to 0.3.6, bugfix release
(Portage version: 2.1.5.2)
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/ChangeLog7
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.3.6.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index fa6dd552fb34..0e67675bb70e 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.11 2008/05/12 02:57:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.12 2008/05/25 23:39:12 remi Exp $
+
+*gtk-vnc-0.3.6 (25 May 2008)
+
+ 25 May 2008; Rémi Cardona <remi@gentoo.org> +gtk-vnc-0.3.6.ebuild:
+ bump to 0.3.6, bugfix release
12 May 2008; Jeroen Roovers <jer@gentoo.org> gtk-vnc-0.3.4.ebuild:
Marked ~hppa (bug #218794).
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.3.6.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.3.6.ebuild
new file mode 100644
index 000000000000..56b47f1b5bc5
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-0.3.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.3.6.ebuild,v 1.1 2008/05/25 23:39:12 remi Exp $
+
+inherit gnome2
+
+DESCRIPTION="VNC viewer widget for GTK."
+HOMEPAGE="http://gtk-vnc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="debug examples python opengl"
+
+# what shall we do about libview
+# TODO: review nsplugin when it will be considered less experimental
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=net-libs/gnutls-1.4
+ python? ( >=dev-python/pygtk-2 )
+ opengl? ( >=x11-libs/gtkglext-1.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_with examples)
+ $(use_with python)
+ $(use_with opengl gtkglext)
+ --with-coroutine=gthread
+ --without-libview"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}