summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-10 09:17:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-10 09:17:59 +0000
commit761db2ab8922885b15a4bef8156d483b8d84b279 (patch)
tree608bf38277327f7f2fd5bd56fba71c90871a2229 /net-libs/libnfnetlink
parentAdd dev-ruby/coderay dependency to fix documentation generation; drop ia64/sp... (diff)
downloadgentoo-2-761db2ab8922885b15a4bef8156d483b8d84b279.tar.gz
gentoo-2-761db2ab8922885b15a4bef8156d483b8d84b279.tar.bz2
gentoo-2-761db2ab8922885b15a4bef8156d483b8d84b279.zip
Refactor warnings and add warning for other case of kernel config name.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libnfnetlink')
-rw-r--r--net-libs/libnfnetlink/ChangeLog8
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-1.0.0.ebuild8
2 files changed, 11 insertions, 5 deletions
diff --git a/net-libs/libnfnetlink/ChangeLog b/net-libs/libnfnetlink/ChangeLog
index d2b3d7ba2822..37e1e0ebcf4c 100644
--- a/net-libs/libnfnetlink/ChangeLog
+++ b/net-libs/libnfnetlink/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libnfnetlink
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/ChangeLog,v 1.29 2009/09/08 17:03:42 ikelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/ChangeLog,v 1.30 2010/01/10 09:17:59 robbat2 Exp $
+
+ 10 Jan 2010; Robin H. Johnson <robbat2@gentoo.org>
+ libnfnetlink-1.0.0.ebuild:
+ Refactor warnings and add warning for other case of kernel config name.
08 Sep 2009; Mike Auty <ikelos@gentoo.org> libnfnetlink-0.0.25.ebuild,
libnfnetlink-0.0.30.ebuild, libnfnetlink-0.0.33.ebuild,
diff --git a/net-libs/libnfnetlink/libnfnetlink-1.0.0.ebuild b/net-libs/libnfnetlink/libnfnetlink-1.0.0.ebuild
index b2049e270e98..19a22931a900 100644
--- a/net-libs/libnfnetlink/libnfnetlink-1.0.0.ebuild
+++ b/net-libs/libnfnetlink/libnfnetlink-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-1.0.0.ebuild,v 1.2 2009/09/08 17:03:42 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-1.0.0.ebuild,v 1.3 2010/01/10 09:17:59 robbat2 Exp $
inherit linux-info
@@ -24,11 +24,13 @@ pkg_setup() {
fi
#netfilter core team has changed some option names with kernel 2.6.20
+ error_common=' is not set when it should be. You can activate it in the Core Netfilter Configuration'
if kernel_is lt 2 6 20 ; then
CONFIG_CHECK="~IP_NF_CONNTRACK_NETLINK"
+ ERROR_IP_NF_CONNTRACK_NETLINK="CONFIG_IP_NF_CONNTRACK_NETLINK:\t${error_common}"
else
CONFIG_CHECK="~NF_CT_NETLINK"
- ERROR_NF_CT_NETLINK="CONFIG_NF_CT_NETLINK:\t is not set when it should be. You can activate it in the Core Netfilter Configuration"
+ ERROR_NF_CT_NETLINK="CONFIG_NF_CT_NETLINK:\t${error_common}"
fi
check_extra_config