summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-28 11:14:42 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-28 11:14:42 +0000
commit353bf1b7954d48eeec3dc3864f0bc652cccab0aa (patch)
tree2c0bf2ea76f696ff279efd04d847bba2f37d7d98 /net-libs/libssh
parentInitial commit of md6sum package. Thanks to AlphatPC@gmail.com for the origin... (diff)
downloadgentoo-2-353bf1b7954d48eeec3dc3864f0bc652cccab0aa.tar.gz
gentoo-2-353bf1b7954d48eeec3dc3864f0bc652cccab0aa.tar.bz2
gentoo-2-353bf1b7954d48eeec3dc3864f0bc652cccab0aa.zip
Add latest RC into testing so it gets some attention. Does work with KDE 4.6.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libssh')
-rw-r--r--net-libs/libssh/ChangeLog8
-rw-r--r--net-libs/libssh/libssh-0.4.91.ebuild59
-rw-r--r--net-libs/libssh/libssh-9999.ebuild17
3 files changed, 77 insertions, 7 deletions
diff --git a/net-libs/libssh/ChangeLog b/net-libs/libssh/ChangeLog
index 94f1476d0487..3e6f6af46b4d 100644
--- a/net-libs/libssh/ChangeLog
+++ b/net-libs/libssh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libssh
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/ChangeLog,v 1.42 2011/03/05 17:00:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/ChangeLog,v 1.43 2011/03/28 11:14:42 scarabeus Exp $
+
+*libssh-0.4.91 (28 Mar 2011)
+
+ 28 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org> +libssh-0.4.91.ebuild,
+ libssh-9999.ebuild:
+ Add latest RC into testing so it gets some attention. Does work with KDE 4.6.
05 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org>
-files/libssh-0.3.0-automagic-crypt.patch, -libssh-0.4.1.ebuild,
diff --git a/net-libs/libssh/libssh-0.4.91.ebuild b/net-libs/libssh/libssh-0.4.91.ebuild
new file mode 100644
index 000000000000..ebd4c0ab07be
--- /dev/null
+++ b/net-libs/libssh/libssh-0.4.91.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/libssh-0.4.91.ebuild,v 1.1 2011/03/28 11:14:42 scarabeus Exp $
+
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+EAPI=4
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="http://www.libssh.org/"
+SRC_URI="http://www.${PN}.org/files/rc/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="debug examples gcrypt pcap +sftp ssh1 server static-libs zlib"
+
+DEPEND="
+ zlib? ( >=sys-libs/zlib-1.2 )
+ !gcrypt? ( >=dev-libs/openssl-0.9.8 )
+ gcrypt? ( >=dev-libs/libgcrypt-1.4 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS README ChangeLog )
+
+src_prepare() {
+ # just install the examples do not compile them
+ sed -i \
+ -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with debug DEBUG_CALLTRACE)
+ $(cmake-utils_use_with debug DEBUG_CRYPTO)
+ $(cmake-utils_use_with gcrypt)
+ $(cmake-utils_use_with pcap)
+ $(cmake-utils_use_with server)
+ $(cmake-utils_use_with sftp)
+ $(cmake-utils_use_with ssh1)
+ $(cmake-utils_use_with static-libs STATIC_LIB)
+ $(cmake-utils_use_with zlib LIBZ)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/examples
+ doins examples/*.{c,h,cpp}
+ fi
+}
diff --git a/net-libs/libssh/libssh-9999.ebuild b/net-libs/libssh/libssh-9999.ebuild
index cb2c2ae2f292..afb7bb0fbb69 100644
--- a/net-libs/libssh/libssh-9999.ebuild
+++ b/net-libs/libssh/libssh-9999.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/libssh-9999.ebuild,v 1.3 2011/02/21 15:09:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/libssh-9999.ebuild,v 1.4 2011/03/28 11:14:42 scarabeus Exp $
-EAPI=3
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+EAPI=4
inherit eutils cmake-utils git
@@ -13,7 +15,7 @@ EGIT_REPO_URI="git://git.libssh.org/projects/libssh.git"
LICENSE="LGPL-2.1"
KEYWORDS=""
SLOT="0"
-IUSE="debug gcrypt examples +sftp ssh1 server static-libs zlib"
+IUSE="debug examples gcrypt pcap +sftp ssh1 server static-libs zlib"
DEPEND="
zlib? ( >=sys-libs/zlib-1.2 )
@@ -22,10 +24,13 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-DOCS=(AUTHORS README ChangeLog)
+DOCS=( AUTHORS README ChangeLog )
src_prepare() {
- sed -i '/add_subdirectory(examples)/s/^/#DONOTWANT/' CMakeLists.txt
+ # just install the examples do not compile them
+ sed -i \
+ -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' \
+ CMakeLists.txt || die
}
src_configure() {
@@ -49,6 +54,6 @@ src_install() {
if use examples; then
insinto /usr/share/doc/"${PF}"/examples
- doins examples/*.c
+ doins examples/*.{c,h,cpp}
fi
}