summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-06-11 19:52:16 +0000
committerMike Frysinger <vapier@gentoo.org>2011-06-11 19:52:16 +0000
commit6aa046edf34e594a8ec686038e2b3d0d6487bd5f (patch)
treedea73514005ba88c6eddb272719b621f03975d9e /net-libs/libtirpc/libtirpc-0.2.2-r1.ebuild
parentRemove duplicate file, bug 371123 (diff)
downloadgentoo-2-6aa046edf34e594a8ec686038e2b3d0d6487bd5f.tar.gz
gentoo-2-6aa046edf34e594a8ec686038e2b3d0d6487bd5f.tar.bz2
gentoo-2-6aa046edf34e594a8ec686038e2b3d0d6487bd5f.zip
Stub out des_crypt for now #370713 by Nicolas Schlumberger, fix building with glibc-2.14 #370663 by Diego Elio Pettenò, restore static lib support, and start installing into / for glibc replacement.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libtirpc/libtirpc-0.2.2-r1.ebuild')
-rw-r--r--net-libs/libtirpc/libtirpc-0.2.2-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-libs/libtirpc/libtirpc-0.2.2-r1.ebuild b/net-libs/libtirpc/libtirpc-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..34ba34e96c9e
--- /dev/null
+++ b/net-libs/libtirpc/libtirpc-0.2.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtirpc/libtirpc-0.2.2-r1.ebuild,v 1.1 2011/06/11 19:52:16 vapier Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
+HOMEPAGE="http://libtirpc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://gentoo/${PN}-glibc-nfs.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="kerberos static-libs"
+
+RDEPEND="kerberos? ( net-libs/libgssglue )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cp -r tirpc "${S}"/ || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.1-fortify.patch
+ epatch "${FILESDIR}"/${PN}-0.2.2-rpc-des-prot.patch
+ > src/des_crypt.c #370713
+}
+
+src_configure() {
+ econf \
+ $(use_enable kerberos gss) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ insinto /etc
+ newins doc/etc_netconfig netconfig || die
+
+ insinto /usr/include/tirpc
+ doins -r "${WORKDIR}"/tirpc/* || die
+
+ # libtirpc replaces rpc support in glibc, so we need it in /
+ gen_usr_ldscript -a tirpc
+
+ # makes sure that the linking order for nfs-utils is proper, as
+ # libtool would inject a libgssglue dependency in the list.
+ use static-libs || find "${D}" -name '*.la' -delete
+}