summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-19 19:01:21 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-19 19:01:21 +0000
commit016e23a40cd207d8ef17fffac7ec12d6c6083570 (patch)
tree06cb6979dda3b4c79225437730eb420d9f8acf42 /net-libs/libtorrent
parentBlock packages that install mp and/or qp (bugs #189857 and #247434). (diff)
downloadgentoo-2-016e23a40cd207d8ef17fffac7ec12d6c6083570.tar.gz
gentoo-2-016e23a40cd207d8ef17fffac7ec12d6c6083570.tar.bz2
gentoo-2-016e23a40cd207d8ef17fffac7ec12d6c6083570.zip
Bumb
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.4.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 8c5ae1cf65a4..8b038d19d456 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.131 2008/11/02 15:35:55 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.132 2008/11/19 19:01:21 loki_val Exp $
+
+*libtorrent-0.12.4 (19 Nov 2008)
+
+ 19 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +libtorrent-0.12.4.ebuild:
+ Bumb
*libtorrent-0.12.3-r2 (02 Nov 2008)
diff --git a/net-libs/libtorrent/libtorrent-0.12.4.ebuild b/net-libs/libtorrent/libtorrent-0.12.4.ebuild
new file mode 100644
index 000000000000..be8d9a157f3c
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.4.ebuild,v 1.1 2008/11/19 19:01:21 loki_val Exp $
+
+inherit base eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug ipv6"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ elibtoolize #Don't remove. Needed for *bsd.
+}
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ --enable-aligned \
+ --enable-static \
+ --enable-shared \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README
+}