summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-08-31 21:38:05 +0000
committerOlivier Crête <tester@gentoo.org>2009-08-31 21:38:05 +0000
commit96a5fe0c02a4cd11b55342e04edafa169451aa04 (patch)
tree413976fb234e4c6f709fcdef2e3d119e2a06e08d /net-libs/loudmouth
parentVersion bump. (diff)
downloadgentoo-2-96a5fe0c02a4cd11b55342e04edafa169451aa04.tar.gz
gentoo-2-96a5fe0c02a4cd11b55342e04edafa169451aa04.tar.bz2
gentoo-2-96a5fe0c02a4cd11b55342e04edafa169451aa04.zip
Import anopatch for asyncns crash from debian
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/ChangeLog6
-rw-r--r--net-libs/loudmouth/files/loudmouth-1.4.3-async-fix.patch30
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild7
3 files changed, 41 insertions, 2 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 9dfffbd4b911..4df399d56f94 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/loudmouth
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.89 2009/07/05 17:13:31 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.90 2009/08/31 21:38:05 tester Exp $
+
+ 31 Aug 2009; Olivier Crête <tester@gentoo.org> loudmouth-1.4.3-r1.ebuild,
+ +files/loudmouth-1.4.3-async-fix.patch:
+ Import anopatch for asyncns crash from debian
*loudmouth-1.4.3-r1 (05 Jul 2009)
diff --git a/net-libs/loudmouth/files/loudmouth-1.4.3-async-fix.patch b/net-libs/loudmouth/files/loudmouth-1.4.3-async-fix.patch
new file mode 100644
index 000000000000..3213d72865aa
--- /dev/null
+++ b/net-libs/loudmouth/files/loudmouth-1.4.3-async-fix.patch
@@ -0,0 +1,30 @@
+--- a/loudmouth/lm-socket.c
++++ b/loudmouth/lm-socket.c
+@@ -1022,7 +1022,7 @@ _lm_socket_create_phase2 (LmSocket *socket, struct addrinfo *ans)
+ if (socket->connect_func) {
+ (socket->connect_func) (socket, FALSE, socket->user_data;
+ }
+- g_free (socket->connect_data);
++ g_free (socket->connect_data);
+ socket->connect_data = NULL;
+ return;
+ }
+@@ -1107,6 +1107,10 @@ lm_socket_create (GMainContext *context,
+ _lm_socket_create_phase1 (socket, NULL, 0);
+ }
+
++#ifndef HAVE_ASYNCNS
++ /* Only do this check if we are not using asyncns or it will crash.
++ * Report and patch by Senko.
++ */
+ if (socket->connect_data == NULL) {
+ /* Open failed synchronously, probably a DNS lookup problem */
+ lm_socket_unref(socket);
+@@ -1118,6 +1122,7 @@ lm_socket_create (GMainContext *context,
+
+ return NULL;
+ }
++#endif /* HAVE_ASYNCNS */
+
+
+ /* If the connection fails synchronously, we don't want to call the
diff --git a/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild b/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild
index 815ea8dc6a3e..56eed74c3b4f 100644
--- a/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild
+++ b/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild,v 1.2 2009/07/06 03:36:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.3-r1.ebuild,v 1.3 2009/08/31 21:38:05 tester Exp $
inherit autotools gnome2
@@ -61,5 +61,10 @@ src_unpack() {
# From debian..
epatch "${FILESDIR}/${P}-drop-stanzas-on-fail.patch"
+ # Don't check for sync dns problems when using asyncns [#33]
+ # From debian..
+ epatch "${FILESDIR}/${P}-async-fix.patch"
+
+
eautoreconf
}