summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-24 13:55:00 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-24 13:55:00 +0000
commit75b27bbc5e96acc6e08b4682ac577f6e4ad7de55 (patch)
tree42e6e8805c7e0b925f56d614c2be62b32e05416b /net-libs/nghttp2
parentKeyword for everyone for nghttp2. (diff)
downloadgentoo-2-75b27bbc5e96acc6e08b4682ac577f6e4ad7de55.tar.gz
gentoo-2-75b27bbc5e96acc6e08b4682ac577f6e4ad7de55.tar.bz2
gentoo-2-75b27bbc5e96acc6e08b4682ac577f6e4ad7de55.zip
Initial ebuild by me.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/ChangeLog11
-rw-r--r--net-libs/nghttp2/metadata.xml12
-rw-r--r--net-libs/nghttp2/nghttp2-0.7.15.ebuild61
-rw-r--r--net-libs/nghttp2/nghttp2-1.0.1.ebuild62
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild62
5 files changed, 208 insertions, 0 deletions
diff --git a/net-libs/nghttp2/ChangeLog b/net-libs/nghttp2/ChangeLog
new file mode 100644
index 000000000000..14d1dea345bf
--- /dev/null
+++ b/net-libs/nghttp2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-libs/nghttp2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/ChangeLog,v 1.1 2015/05/24 13:55:00 vapier Exp $
+
+*nghttp2-9999 (24 May 2015)
+*nghttp2-1.0.1 (24 May 2015)
+*nghttp2-0.7.15 (24 May 2015)
+
+ 24 May 2015; Mike Frysinger <vapier@gentoo.org> +metadata.xml,
+ +nghttp2-0.7.15.ebuild, +nghttp2-1.0.1.ebuild, +nghttp2-9999.ebuild:
+ Initial ebuild by me.
diff --git a/net-libs/nghttp2/metadata.xml b/net-libs/nghttp2/metadata.xml
new file mode 100644
index 000000000000..027406946e08
--- /dev/null
+++ b/net-libs/nghttp2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name='hpack-tools'>Install HPACK (header compression) helper tools</flag>
+ <flag name='jemalloc'>Use <pkg>dev-libs/jemalloc</pkg> for memory allocation</flag>
+ <flag name='utils'>Install nghttp, nghttpd and nghttpx</flag>
+</use>
+</pkgmetadata>
diff --git a/net-libs/nghttp2/nghttp2-0.7.15.ebuild b/net-libs/nghttp2/nghttp2-0.7.15.ebuild
new file mode 100644
index 000000000000..384172c36b56
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-0.7.15.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/nghttp2-0.7.15.ebuild,v 1.1 2015/05/24 13:55:00 vapier Exp $
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.5" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ >=dev-libs/openssl-1.0.2
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/net-libs/nghttp2/nghttp2-1.0.1.ebuild b/net-libs/nghttp2/nghttp2-1.0.1.ebuild
new file mode 100644
index 000000000000..6019f25807c5
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/nghttp2-1.0.1.ebuild,v 1.1 2015/05/24 13:55:00 vapier Exp $
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ # Disabled until new curl & mod_h2 releases are made for the new API.
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ >=dev-libs/openssl-1.0.2
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
new file mode 100644
index 000000000000..178e4cc47dc4
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/nghttp2-9999.ebuild,v 1.1 2015/05/24 13:55:00 vapier Exp $
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ # Disabled until new curl & mod_h2 releases are made for the new API.
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ >=dev-libs/openssl-1.0.2
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}