summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-12-28 21:35:27 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-12-28 21:35:27 +0000
commit9267359108a0125d07a48fcce046a494b4ca35cb (patch)
tree9d66f3a1f13083b49a2cee97aac022fe98c749c6 /net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild
parentRemoved dev-db/phppgadmin-4.2.1, added 4.2.2 in response to sec issue #250451. (diff)
downloadgentoo-2-9267359108a0125d07a48fcce046a494b4ca35cb.tar.gz
gentoo-2-9267359108a0125d07a48fcce046a494b4ca35cb.tar.bz2
gentoo-2-9267359108a0125d07a48fcce046a494b4ca35cb.zip
Version bump (bug #245731), thanks to Atman Sense <atman.sense@zise.de>. Closes bug #225931 too.
(Portage version: 2.2_rc19/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild
new file mode 100644
index 000000000000..f21047f840cd
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild,v 1.1 2008/12/28 21:35:27 coldwind Exp $
+
+inherit eutils autotools
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE="debug examples python test"
+
+DEPEND="
+ >=dev-libs/boost-1.34
+ || ( >=dev-libs/boost-1.35 dev-cpp/asio )
+ sys-libs/zlib
+ !net-libs/libtorrent"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ax_python_path.patch
+ eautoreconf
+}
+
+src_compile() {
+ #use multi-threading versions of boost libs
+ local BOOST_LIBS="
+ --with-boost-system=boost_system-mt \
+ --with-boost-asio=boost_system-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-python=boost_python-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ #TODO: We might want to add 'use debug -> --with-logging=verbose
+ econf \
+ $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ --with-zlib=system \
+ --with-asio=system \
+ ${BOOST_LIBS} \
+ LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}