summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-06-06 16:30:06 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-06-06 16:30:06 +0000
commit08ad7102a9cb5510944b5c6155265562dbe7918a (patch)
tree37375995b04fcb6423a4300d56b5696e3abc5b5d /net-libs/rb_libtorrent
parentAdd dev-lang/nasm dep on x86, bug 272658 (diff)
downloadgentoo-2-08ad7102a9cb5510944b5c6155265562dbe7918a.tar.gz
gentoo-2-08ad7102a9cb5510944b5c6155265562dbe7918a.tar.bz2
gentoo-2-08ad7102a9cb5510944b5c6155265562dbe7918a.zip
Version bump
(Portage version: 2.1.6.11/cvs/Linux ia64)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index ae45f0fc86d4..8759a1bb0428 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.55 2009/03/29 16:55:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.56 2009/06/06 16:30:06 armin76 Exp $
+
+*rb_libtorrent-0.14.4 (06 Jun 2009)
+
+ 06 Jun 2009; Raúl Porcel <armin76@gentoo.org>
+ +rb_libtorrent-0.14.4.ebuild:
+ Version bump
29 Mar 2009; Raúl Porcel <armin76@gentoo.org>
rb_libtorrent-0.14.2.ebuild:
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild
new file mode 100644
index 000000000000..80f01f249b60
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.4.ebuild,v 1.1 2009/06/06 16:30:06 armin76 Exp $
+
+inherit eutils autotools
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE="debug examples python test"
+
+DEPEND="
+ >=dev-libs/boost-1.34
+ || ( >=dev-libs/boost-1.35 dev-cpp/asio )
+ sys-libs/zlib
+ !net-libs/libtorrent"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ #use multi-threading versions of boost libs
+ local BOOST_LIBS="
+ --with-boost-system=boost_system-mt \
+ --with-boost-asio=boost_system-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-python=boost_python-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ #TODO: We might want to add 'use debug -> --with-logging=verbose
+ econf \
+ $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ --with-zlib=system \
+ --with-asio=system \
+ ${BOOST_LIBS} \
+ LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}