summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-17 13:17:40 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-17 13:17:40 +0000
commit67235d172911ed8f1d63636b6d7e28d8a2335c69 (patch)
tree1a86016c7bb300e34ec9a31a7d7effa651811b4a /net-libs/rb_libtorrent
parentMasked sci-visualization/qtiplot as I broke it (diff)
downloadgentoo-2-67235d172911ed8f1d63636b6d7e28d8a2335c69.tar.gz
gentoo-2-67235d172911ed8f1d63636b6d7e28d8a2335c69.tar.bz2
gentoo-2-67235d172911ed8f1d63636b6d7e28d8a2335c69.zip
Add ssl useflag for encryption purposes. Fix debug useflag usage
(Portage version: 2.2_rc97/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog6
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.4.ebuild11
2 files changed, 12 insertions, 5 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 49a60f287f66..7469c3da6cf4 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.92 2010/10/05 19:09:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.93 2010/10/17 13:17:40 hwoarang Exp $
+
+ 17 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ rb_libtorrent-0.15.4.ebuild:
+ Add ssl useflag for encryption purposes. Fix debug useflag usage
*rb_libtorrent-0.15.4 (05 Oct 2010)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.15.4.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.4.ebuild
index ba19e67db094..b05d0fbb750c 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.15.4.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.4.ebuild,v 1.1 2010/10/05 19:09:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.4.ebuild,v 1.2 2010/10/17 13:17:40 hwoarang Exp $
EAPI="2"
inherit eutils versionator
@@ -16,7 +16,7 @@ SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="debug doc examples python"
+IUSE="debug doc examples python ssl"
RESTRICT="test"
DEPEND="|| ( >=dev-libs/boost-1.35
@@ -24,7 +24,9 @@ DEPEND="|| ( >=dev-libs/boost-1.35
python? ( >=dev-libs/boost-1.35.0-r5[python] dev-lang/python:2.6[threads] )
=sys-devel/libtool-2.2*
sys-libs/zlib
- examples? ( !net-p2p/mldonkey )" #292998
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl )"
+
RDEPEND="${DEPEND}"
src_configure() {
@@ -42,12 +44,13 @@ src_configure() {
BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
local LOGGING
- use debug && LOGGING="--with-logging=verbose"
+ use debug && LOGGING="--enable-logging=verbose --enable-statistics"
econf $(use_enable debug) \
$(use_enable test tests) \
$(use_enable examples) \
$(use_enable python python-binding) \
+ $(use_enable ssl encryption) \
--with-zlib=system \
${LOGGING} \
--with-boost=${BOOST_INC} \