summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-11-16 13:07:26 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-11-16 13:07:26 +0000
commit0ea3b8d48fe2a82049f54ed3eeaed94a8f5665d9 (patch)
treea2fe76d350bb53b02ff9a4fe63dfe4c6b063a9fe /net-libs/wvstreams/wvstreams-3.75-r1.ebuild
parentstable on ppc gsla: 71311 (Manifest recommit) (diff)
downloadgentoo-2-0ea3b8d48fe2a82049f54ed3eeaed94a8f5665d9.tar.gz
gentoo-2-0ea3b8d48fe2a82049f54ed3eeaed94a8f5665d9.tar.bz2
gentoo-2-0ea3b8d48fe2a82049f54ed3eeaed94a8f5665d9.zip
version bump and uclibc patch from bug #70974
Diffstat (limited to 'net-libs/wvstreams/wvstreams-3.75-r1.ebuild')
-rw-r--r--net-libs/wvstreams/wvstreams-3.75-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/net-libs/wvstreams/wvstreams-3.75-r1.ebuild b/net-libs/wvstreams/wvstreams-3.75-r1.ebuild
new file mode 100644
index 000000000000..13d446ef107a
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-3.75-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.75-r1.ebuild,v 1.1 2004/11/16 13:07:26 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://open.nit.ca/wiki/?page=WvStreams"
+SRC_URI="http://people.nit.ca/~jim/${P}.0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc -alpha ~amd64 -hppa ~ppc"
+IUSE="gtk qt oggvorbis speex fam gdbm pam fftw tcltk uclibc"
+
+RDEPEND="gtk? ( >=x11-libs/gtk+-2.2.0 )
+ qt? ( >=x11-libs/qt-3.0.5 )
+ oggvorbis? ( >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0 )
+ speex? ( media-libs/speex !=media-libs/speex-1.1.4 )
+ fam? ( >=app-admin/fam-2.7.0 )
+ >=sys-libs/db-3
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ pam? ( >=sys-libs/pam-0.75 )
+ >=sys-libs/zlib-1.1.4
+ dev-libs/openssl
+ fftw? ( dev-libs/fftw )
+ tcltk? ( dev-lang/tcl
+ dev-lang/swig )"
+
+DEPEND="${RDEPEND}
+ virtual/libc
+ tcltk? ( >=dev-lang/tcl-8.4*
+ >=sys-devel/autoconf-2.59 )"
+
+S=${WORKDIR}/${P}.0
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-makefile.patch
+ epatch ${FILESDIR}/${P}-fPIC.patch
+
+ #gcc-3.4 fix
+ epatch ${FILESDIR}/${P}-gcc34.patch
+
+ use uclibc && epatch ${FILESDIR}/wvcrash-uclibc-gentoo.patch
+
+ if useq tcltk;
+ then
+ epatch ${FILESDIR}/${P}-tcl_8_4.patch
+ autoconf || die
+ fi
+}
+
+src_compile() {
+ econf `use_with gtk` \
+ `use_with qt` \
+ `use_with oggvorbis ogg` \
+ `use_with oggvorbis vorbis` \
+ `use_with fam` \
+ `use_with gdbm` \
+ `use_with pam` \
+ `use_with qt` \
+ `use_with speex` \
+ `use_with fftw` \
+ `use_with tcltk tcl` \
+ --enable-verbose \
+ --with-bdb \
+ --with-openssl \
+ --with-zlib \
+ || die
+ make || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}