summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-03-16 21:10:54 +0000
committerThomas Sachau <tommy@gentoo.org>2011-03-16 21:10:54 +0000
commit24b2ff52ae09fde6d84c719cafb83435ba430a12 (patch)
tree48cee853919f401d622eaf0c71fa374d128713da /net-libs
parentppc64 stable wrt #349607 (diff)
downloadgentoo-2-24b2ff52ae09fde6d84c719cafb83435ba430a12.tar.gz
gentoo-2-24b2ff52ae09fde6d84c719cafb83435ba430a12.tar.bz2
gentoo-2-24b2ff52ae09fde6d84c719cafb83435ba430a12.zip
Version bump for bug 358783, drop old version
(Portage version: 2.2.0_alpha26-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/polarssl/ChangeLog10
-rw-r--r--net-libs/polarssl/polarssl-0.14.2.ebuild (renamed from net-libs/polarssl/polarssl-0.12.0.ebuild)28
2 files changed, 26 insertions, 12 deletions
diff --git a/net-libs/polarssl/ChangeLog b/net-libs/polarssl/ChangeLog
index c22fd27c209f..3744122806af 100644
--- a/net-libs/polarssl/ChangeLog
+++ b/net-libs/polarssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/polarssl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.13 2010/10/11 18:49:37 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.14 2011/03/16 21:10:54 tommy Exp $
+
+*polarssl-0.14.2 (16 Mar 2011)
+
+ 16 Mar 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ -polarssl-0.12.0.ebuild, +polarssl-0.14.2.ebuild:
+ Version bump for bug 358783, drop old version
11 Oct 2010; Jeroen Roovers <jer@gentoo.org> polarssl-0.14.0.ebuild:
Stable for HPPA (bug #332361).
diff --git a/net-libs/polarssl/polarssl-0.12.0.ebuild b/net-libs/polarssl/polarssl-0.14.2.ebuild
index 9ff58d1461b1..2a34974b7b6b 100644
--- a/net-libs/polarssl/polarssl-0.12.0.ebuild
+++ b/net-libs/polarssl/polarssl-0.14.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-0.12.0.ebuild,v 1.5 2010/07/11 15:13:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-0.14.2.ebuild,v 1.1 2011/03/16 21:10:54 tommy Exp $
+
+EAPI=2
inherit eutils
@@ -10,29 +12,35 @@ SRC_URI="http://polarssl.org/code/download/${P}-gpl.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples sse2"
-src_compile() {
- cd "${S}/library"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.14.0-{makefile,ldflags}.patch
+ cd library
if use sse2 ; then
sed -i '15iCFLAGS += -DHAVE_SSE2 -fPIC' Makefile
else
sed -i '15iCFLAGS += -fPIC' Makefile
fi
- epatch "${FILESDIR}"/${P}-makefile.patch
- emake libpolarssl.so || die "emake failed"
+}
+
+src_compile() {
+ #cd library
+ emake -C library libpolarssl.so || die "emake failed"
if use examples ; then
- cd "${S}"/programs
- emake all || die "emake failed"
+ #cd programs
+ emake -C programs all || die "emake failed"
fi
}
src_test() {
- cd "${S}"/programs
+ cd programs
emake test/selftest || die "emake selftest failed"
LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" ./test/selftest || die "selftest failed"
+ cd "${S}"
+ emake check || die
}
src_install() {