summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 17:53:26 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 17:53:26 +0000
commit416d34e0e0427991a2bfaf0c0d0f6a1ce7ac2147 (patch)
treec30c7c2bb6f68e3bcfe79e55462be000b79f41ca /net-libs
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-416d34e0e0427991a2bfaf0c0d0f6a1ce7ac2147.tar.gz
gentoo-2-416d34e0e0427991a2bfaf0c0d0f6a1ce7ac2147.tar.bz2
gentoo-2-416d34e0e0427991a2bfaf0c0d0f6a1ce7ac2147.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsoup/ChangeLog7
-rw-r--r--net-libs/libsoup/libsoup-2.42.0.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index c571371a578d..0f126a49c051 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libsoup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.298 2013/02/25 08:55:44 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.299 2013/03/28 17:53:26 pacho Exp $
+
+*libsoup-2.42.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +libsoup-2.42.0.ebuild:
+ Version bump for Gnome 3.8
25 Feb 2013; Zac Medico <zmedico@gentoo.org> libsoup-2.40.2.ebuild,
libsoup-2.40.3.ebuild:
diff --git a/net-libs/libsoup/libsoup-2.42.0.ebuild b/net-libs/libsoup/libsoup-2.42.0.ebuild
new file mode 100644
index 000000000000..733378e8e68e
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.42.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.42.0.ebuild,v 1.1 2013/03/28 17:53:26 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://live.gnome.org/LibSoup"
+
+LICENSE="LGPL-2+"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="debug +introspection samba ssl test gnome"
+
+RDEPEND=">=dev-libs/glib-2.35.0:2
+ >=dev-libs/libxml2-2:2
+ dev-db/sqlite:3
+ >=net-libs/glib-networking-2.30.0[ssl?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ samba? ( net-fs/samba )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ virtual/pkgconfig"
+# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+# dev-lang/php[apache2,xmlrpc]
+# net-misc/curl
+# net-libs/glib-networking[ssl])"
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests (bug #226271)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ gnome2_src_configure \
+ --disable-static \
+ --disable-tls-check \
+ $(use_with gnome) \
+ --without-apache-httpd \
+ $(use_enable introspection) \
+ $(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)
+
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+ gnome2_src_configure
+}