summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-06-19 20:39:28 +0000
committerJeroen Roovers <jer@gentoo.org>2012-06-19 20:39:28 +0000
commit4434cab9a55f7b8802da9aa2875e4e93d1652eb9 (patch)
treee9494351ac3bae522aa9f370e1e812f941ac599b /net-libs
parentSecurity bump. Imported from java-overlay. #421031 (diff)
downloadgentoo-2-4434cab9a55f7b8802da9aa2875e4e93d1652eb9.tar.gz
gentoo-2-4434cab9a55f7b8802da9aa2875e4e93d1652eb9.tar.bz2
gentoo-2-4434cab9a55f7b8802da9aa2875e4e93d1652eb9.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/ChangeLog7
-rw-r--r--net-libs/libpcap/libpcap-1.3.0.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index b15c568da28c..7198afc7365e 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.167 2012/04/26 14:29:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.168 2012/06/19 20:39:28 jer Exp $
+
+*libpcap-1.3.0 (19 Jun 2012)
+
+ 19 Jun 2012; Jeroen Roovers <jer@gentoo.org> +libpcap-1.3.0.ebuild:
+ Version bump.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> libpcap-1.2.1.ebuild:
keyword ~amd64-fbsd
diff --git a/net-libs/libpcap/libpcap-1.3.0.ebuild b/net-libs/libpcap/libpcap-1.3.0.ebuild
new file mode 100644
index 000000000000..08153cc4576e
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.3.0.ebuild,v 1.1 2012/06/19 20:39:28 jer Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth ipv6 libnl static-libs"
+
+RDEPEND="bluetooth? ( net-wireless/bluez )
+ libnl? ( dev-libs/libnl:1.1 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+DOCS=( CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel} )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
+ # Prefix' Solaris uses GNU ld
+ sed -i -e 's/freebsd\*/freebsd*|solaris*/' \
+ -e 's/sparc64\*/sparc64*|sparcv9*/' aclocal.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_with libnl) \
+ $(use_enable bluetooth)
+}
+
+src_compile() {
+ emake all shared
+}
+
+src_install() {
+ default
+
+ # remove static libraries (--disable-static does not work)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h
+ fi
+}