summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-08-20 23:04:44 +0000
committerJeroen Roovers <jer@gentoo.org>2011-08-20 23:04:44 +0000
commit7744bf68ec39bbae436e3673c6de70589047f027 (patch)
tree181b3677423d5ff6e1d1a56e19dc2baa73bb22b4 /net-libs
parentRemove hal from use.mask. It's masked by base/use.mask now. (diff)
downloadgentoo-2-7744bf68ec39bbae436e3673c6de70589047f027.tar.gz
gentoo-2-7744bf68ec39bbae436e3673c6de70589047f027.tar.bz2
gentoo-2-7744bf68ec39bbae436e3673c6de70589047f027.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/ChangeLog7
-rw-r--r--net-libs/libssh2/libssh2-1.2.9.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 29ebf5d66e00..88b5821f8601 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.37 2011/05/10 20:00:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.38 2011/08/20 23:04:44 jer Exp $
+
+*libssh2-1.2.9 (20 Aug 2011)
+
+ 20 Aug 2011; Jeroen Roovers <jer@gentoo.org> +libssh2-1.2.9.ebuild:
+ Version bump.
*libssh2-1.2.8-r1 (10 May 2011)
diff --git a/net-libs/libssh2/libssh2-1.2.9.ebuild b/net-libs/libssh2/libssh2-1.2.9.ebuild
new file mode 100644
index 000000000000..a938dea35d40
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.2.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.2.9.ebuild,v 1.1 2011/08/20 23:04:44 jer Exp $
+
+EAPI="4"
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-macos ~x86-solaris"
+IUSE="gcrypt static-libs zlib"
+
+DEPEND="!gcrypt? ( dev-libs/openssl )
+ gcrypt? ( dev-libs/libgcrypt )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf
+
+ if use gcrypt; then
+ myconf="--with-libgcrypt"
+ else
+ myconf="--with-openssl"
+ fi
+
+ econf \
+ $(use_with zlib libz) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]]; then #286741
+ ewarn "Some tests require real user that is allowed to login."
+ ewarn "ssh2.sh test disabled."
+ sed -e 's:ssh2.sh::' -i tests/Makefile
+ fi
+ emake check
+}
+
+src_install() {
+ default
+ dodoc README
+ use static-libs || remove_libtool_files
+}