summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2005-03-16 00:26:31 +0000
committerScott W Taylor <swtaylor@gentoo.org>2005-03-16 00:26:31 +0000
commitd575db6dac425f8ee5d980d30564687634cab2ea (patch)
tree39b4c1aa9456ce78be7d34a6244f54e5b43c79a8 /net-libs
parentAdded missing emake. Retrieved vital brain cells. (diff)
downloadgentoo-2-d575db6dac425f8ee5d980d30564687634cab2ea.tar.gz
gentoo-2-d575db6dac425f8ee5d980d30564687634cab2ea.tar.bz2
gentoo-2-d575db6dac425f8ee5d980d30564687634cab2ea.zip
change vpopmail detection for #85391
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/courier-authlib/ChangeLog8
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.52-r1.ebuild161
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.53.ebuild4
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.54.20050224.ebuild4
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.54.ebuild4
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.55.ebuild4
-rw-r--r--net-libs/courier-authlib/files/digest-courier-authlib-0.52-r11
7 files changed, 15 insertions, 171 deletions
diff --git a/net-libs/courier-authlib/ChangeLog b/net-libs/courier-authlib/ChangeLog
index e1d293cfb795..36aa115c7f2a 100644
--- a/net-libs/courier-authlib/ChangeLog
+++ b/net-libs/courier-authlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/courier-authlib
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/ChangeLog,v 1.30 2005/03/04 09:44:01 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/ChangeLog,v 1.31 2005/03/16 00:26:31 swtaylor Exp $
+
+ 15 Mar 2005; Scott W Taylor <swtaylor@gentoo.org>
+ -courier-authlib-0.52-r1.ebuild, courier-authlib-0.53.ebuild,
+ courier-authlib-0.54.ebuild, courier-authlib-0.54.20050224.ebuild,
+ courier-authlib-0.55.ebuild:
+ change vpopmail detection for #85391
*courier-authlib-0.55 (04 Mar 2005)
diff --git a/net-libs/courier-authlib/courier-authlib-0.52-r1.ebuild b/net-libs/courier-authlib/courier-authlib-0.52-r1.ebuild
deleted file mode 100644
index 02f25653d42e..000000000000
--- a/net-libs/courier-authlib/courier-authlib-0.52-r1.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.52-r1.ebuild,v 1.4 2005/01/31 23:50:08 swtaylor Exp $
-
-inherit eutils gnuconfig
-
-DESCRIPTION="courier authentication library"
-[ -z "${PV/?.??/}" ] && SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
-[ -z "$SRC_URI" ] && SRC_URI="http://www.courier-mta.org/beta/courier-authlib/${P%%_pre}.tar.bz2"
-HOMEPAGE="http://www.courier-mta.org/"
-S="${WORKDIR}/${P%%_pre}"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 alpha amd64 arm hppa ia64 mips ppc s390 sparc ppc64"
-IUSE="postgres ldap mysql berkdb gdbm pam crypt uclibc debug"
-
-DEPEND="virtual/libc
- gdbm? ( sys-libs/gdbm )
- !gdbm? ( >=sys-devel/autoconf-2.5 sys-libs/db )
- >=dev-libs/openssl-0.9.6
- pam? ( >=sys-libs/pam-0.75 )
- mysql? ( >=dev-db/mysql-3.23.36 )
- ldap? ( >=net-nds/openldap-1.2.11 )
- postgres? ( >=dev-db/postgresql-7.2 )"
-
-RDEPEND="virtual/libc
- gdbm? ( sys-libs/gdbm )
- !gdbm? ( sys-libs/db )"
-
-src_unpack() {
- if ! has_version 'dev-tcltk/expect' ; then
- ewarn 'The dev-tcltk/expect package is not installed.'
- einfo 'Without it, you will not be able to change system login passwords.'
- einfo 'However non-system authentication modules (LDAP, MySQL, PostgreSQL,'
- einfo 'and others) will work just fine.'
- fi
- unpack ${A}
- cd ${S}
- sed -e"s|^chk_file .* |&\${DESTDIR}|g" -i.orig authmigrate.in
- use uclibc && sed -i -e 's:linux-gnu\*:linux-gnu\*\ \|\ linux-uclibc:' config.sub
- if ! use gdbm ; then
- epatch ${FILESDIR}/configure-db4.patch
- export WANT_AUTOCONF="2.5"
- gnuconfig_update
- libtoolize --copy --force
- ebegin "Recreating configure"
- autoconf || die "recreate configure failed"
- eend $?
- cd ${S}/bdbobj
- libtoolize --copy --force
- ebegin "Recreating bdbobj/configure"
- autoconf || die "recreate bdbobj/configure failed"
- eend $?
- fi
- sed -i -e'/for dir in/a@@INDENT@@/etc/courier-imap \\' ${S}/authmigrate.in
- sed -i -e'/for dir in/a@@INDENT@@/etc/courier/authlib \\' ${S}/authmigrate.in
- sed -i -e"s|@@INDENT@@| |g" ${S}/authmigrate.in
- sed -i -e"s|\$sbindir/makeuserdb||g" ${S}/authmigrate.in
-}
-
-src_compile() {
- local myconf
- myconf="`use_with pam authpam` `use_with ldap authldap`"
-
- if use berkdb ; then
- use gdbm && \
- einfo "Both gdbm and berkdb selected. Using gdbm." || \
- myconf="${myconf} --with-db=db"
- fi
- use gdbm && myconf="${myconf} --with-db=gdbm"
-
- if [ -f /var/vpopmail/etc/lib_deps ]; then
- myconf="${myconf} --with-authvchkpw --without-authmysql --without-authpgsql"
- use mysql && ewarn "vpopmail found. authmysql will not be built."
- use postgres && ewarn "vpopmail found. authpgsql will not be built."
- else
- myconf="${myconf} --without-authvchkpw `use_with mysql authmysql` `use_with postgres authpgsql`"
- fi
-
- use debug && myconf="${myconf} debug=true"
-
- einfo "Configuring courier-authlib: ${myconf}"
-
- econf \
- --sysconfdir=/etc/courier \
- --datadir=/usr/share/courier \
- --libexecdir=/usr/$(get_libdir)/courier \
- --localstatedir=/var/lib/courier \
- --sharedstatedir=/var/lib/courier/com \
- --with-authdaemonvar=/var/lib/courier/authdaemon \
- --with-authshadow \
- --without-redhat \
- --with-mailuser=mail \
- --with-mailgroup=mail \
- --cache-file=${S}/configuring.cache \
- ${myconf} || die "bad ./configure"
- emake || die "Compile problem"
-}
-
-orderfirst() {
- file="${D}/etc/courier/authlib/${1}" ; option="${2}" ; param="${3}"
- if [ -e "${file}" ] ; then
- orig="`grep \"^${option}=\" ${file} | cut -d'\"' -f 2`"
- new="${option}=\"${param} `echo ${orig} | sed -e\"s/${param}//g\" -e\"s/ / /g\"`\""
- sed -i -e"s/^${option}=.*$/${new}/" ${file}
- fi
-}
-
-finduserdb() {
- for dir in \
- /etc/courier/authlib /etc/courier /etc/courier-imap \
- /usr/lib/courier/etc /usr/lib/courier-imap/etc \
- /usr/local/etc /usr/local/etc/courier /usr/local/courier/etc \
- /usr/local/lib/courier/etc /usr/local/lib/courier-imap/etc \
- /usr/local/share/sqwebmail /usr/local/etc/courier-imap ; do
- [ -e "$dir/userdb" ] && ( echo "found $dir/userdb" ; \
- cp -v $dir/userdb ${D}/etc/courier/authlib/ ; continue )
- done
-}
-
-src_install() {
- diropts -o mail -g mail
- dodir /etc/courier
- keepdir /var/lib/courier/authdaemon
- keepdir /etc/courier/authlib
- emake install DESTDIR="${D}" || die "install"
- emake install-migrate DESTDIR="${D}" || die "migrate"
- [ ! -e "${D}/etc/courier/authlib/userdb" ] && finduserdb
- emake install-configure DESTDIR="${D}" || die "configure"
- rm -vf ${D}/etc/courier/authlib/*.bak
- chown mail:mail ${D}/etc/courier/authlib/*
- for y in ${D}/etc/courier/authlib/*.dist ; do
- [ ! -e "${y%%.dist}" ] && cp -v ${y} ${y%%.dist}
- done
- use pam && orderfirst authdaemonrc authmodulelist authpam
- use ldap && orderfirst authdaemonrc authmodulelist authldap
- use postgres && orderfirst authdaemonrc authmodulelist authpgsql
- use mysql && orderfirst authdaemonrc authmodulelist authmysql
- dodoc AUTHORS COPYING ChangeLog* INSTALL NEWS README
- dohtml README.html README_authlib.html NEWS.html INSTALL.html README.authdebug.html
- use mysql && ( dodoc README.authmysql.myownquery ; dohtml README.authmysql.html )
- use postgres && dohtml README.authpostgres.html
- use ldap && ( dodoc README.ldap ; dodir /etc/openldap/schema ; \
- cp authldap.schema ${D}/etc/openldap/schema/ )
- dodir /etc/init.d
- exeinto /etc/init.d
- newexe ${FILESDIR}/courier-authlib-initd courier-authlib || die "init.d failed"
-}
-
-pkg_postinst() {
- [ -e /etc/courier/authlib/userdb ] && \
- ( einfo "running makeuserdb" ; makeuserdb )
- # Suggest cleaning out the following old files
- list="`find /etc/courier -type f -maxdepth 1 | grep \"^/etc/courier/auth\"`"
- if [ ! -z "${list}" ] ; then
- ewarn "Courier authentication files are now in /etc/courier/authlib/"
- einfo "The following files are no longer needed and can likely be removed:"
- einfo " rm `echo \"${list}\" | xargs echo`"
- fi
-}
diff --git a/net-libs/courier-authlib/courier-authlib-0.53.ebuild b/net-libs/courier-authlib/courier-authlib-0.53.ebuild
index c0c4d9a8b65d..810000984d13 100644
--- a/net-libs/courier-authlib/courier-authlib-0.53.ebuild
+++ b/net-libs/courier-authlib/courier-authlib-0.53.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.53.ebuild,v 1.3 2005/01/31 23:50:08 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.53.ebuild,v 1.4 2005/03/16 00:26:31 swtaylor Exp $
inherit eutils gnuconfig
@@ -70,7 +70,7 @@ src_compile() {
fi
use gdbm && myconf="${myconf} --with-db=gdbm"
- if [ -f /var/vpopmail/etc/lib_deps ]; then
+ if [ has_version net-mail/vpopmail ]; then
myconf="${myconf} --with-authvchkpw --without-authmysql --without-authpgsql"
use mysql && ewarn "vpopmail found. authmysql will not be built."
use postgres && ewarn "vpopmail found. authpgsql will not be built."
diff --git a/net-libs/courier-authlib/courier-authlib-0.54.20050224.ebuild b/net-libs/courier-authlib/courier-authlib-0.54.20050224.ebuild
index 9023d71b6a0c..5a57f71aef86 100644
--- a/net-libs/courier-authlib/courier-authlib-0.54.20050224.ebuild
+++ b/net-libs/courier-authlib/courier-authlib-0.54.20050224.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.54.20050224.ebuild,v 1.1 2005/02/25 23:09:36 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.54.20050224.ebuild,v 1.2 2005/03/16 00:26:31 swtaylor Exp $
inherit eutils gnuconfig
@@ -70,7 +70,7 @@ src_compile() {
fi
use gdbm && myconf="${myconf} --with-db=gdbm"
- if [ -f /var/vpopmail/etc/lib_deps ]; then
+ if [ has_version net-mail/vpopmail ]; then
myconf="${myconf} --with-authvchkpw --without-authmysql --without-authpgsql"
use mysql && ewarn "vpopmail found. authmysql will not be built."
use postgres && ewarn "vpopmail found. authpgsql will not be built."
diff --git a/net-libs/courier-authlib/courier-authlib-0.54.ebuild b/net-libs/courier-authlib/courier-authlib-0.54.ebuild
index e5cabaa6ce0f..2095a3ff67a5 100644
--- a/net-libs/courier-authlib/courier-authlib-0.54.ebuild
+++ b/net-libs/courier-authlib/courier-authlib-0.54.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.54.ebuild,v 1.1 2005/02/13 20:06:56 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.54.ebuild,v 1.2 2005/03/16 00:26:31 swtaylor Exp $
inherit eutils gnuconfig
@@ -70,7 +70,7 @@ src_compile() {
fi
use gdbm && myconf="${myconf} --with-db=gdbm"
- if [ -f /var/vpopmail/etc/lib_deps ]; then
+ if [ has_version net-mail/vpopmail ]; then
myconf="${myconf} --with-authvchkpw --without-authmysql --without-authpgsql"
use mysql && ewarn "vpopmail found. authmysql will not be built."
use postgres && ewarn "vpopmail found. authpgsql will not be built."
diff --git a/net-libs/courier-authlib/courier-authlib-0.55.ebuild b/net-libs/courier-authlib/courier-authlib-0.55.ebuild
index b32cf60f7f8f..fd15090b96d2 100644
--- a/net-libs/courier-authlib/courier-authlib-0.55.ebuild
+++ b/net-libs/courier-authlib/courier-authlib-0.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.55.ebuild,v 1.1 2005/03/04 09:44:01 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.55.ebuild,v 1.2 2005/03/16 00:26:31 swtaylor Exp $
inherit eutils gnuconfig
@@ -70,7 +70,7 @@ src_compile() {
fi
use gdbm && myconf="${myconf} --with-db=gdbm"
- if [ -f /var/vpopmail/etc/lib_deps ]; then
+ if [ has_version net-mail/vpopmail ]; then
myconf="${myconf} --with-authvchkpw --without-authmysql --without-authpgsql"
use mysql && ewarn "vpopmail found. authmysql will not be built."
use postgres && ewarn "vpopmail found. authpgsql will not be built."
diff --git a/net-libs/courier-authlib/files/digest-courier-authlib-0.52-r1 b/net-libs/courier-authlib/files/digest-courier-authlib-0.52-r1
deleted file mode 100644
index 2f1822863523..000000000000
--- a/net-libs/courier-authlib/files/digest-courier-authlib-0.52-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2ad6837c1eec7582f8634c320f45b2dc courier-authlib-0.52.tar.bz2 1965591