summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-14 02:39:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-14 02:39:19 +0000
commitd60323a3793c33c27d75df66d10b16e97aaef2b4 (patch)
tree5f1b85dc7264e24bade472bff4318f6bbc27611b /net-libs
parentVersion bump, bug #421761 (diff)
downloadgentoo-2-d60323a3793c33c27d75df66d10b16e97aaef2b4.tar.gz
gentoo-2-d60323a3793c33c27d75df66d10b16e97aaef2b4.tar.bz2
gentoo-2-d60323a3793c33c27d75df66d10b16e97aaef2b4.zip
Bump, fixes #460784 #461654
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/ChangeLog7
-rw-r--r--net-libs/nodejs/nodejs-0.10.0.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index 256da7262089..b0c56bdec3e6 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.74 2013/03/07 04:11:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.75 2013/03/14 02:39:19 patrick Exp $
+
+*nodejs-0.10.0 (14 Mar 2013)
+
+ 14 Mar 2013; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.0.ebuild:
+ Bump, fixes #460784 #461654
*nodejs-0.9.12 (07 Mar 2013)
diff --git a/net-libs/nodejs/nodejs-0.10.0.ebuild b/net-libs/nodejs/nodejs-0.10.0.ebuild
new file mode 100644
index 000000000000..87161457d77d
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.10.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.0.ebuild,v 1.1 2013/03/14 02:39:19 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/python-json"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr --openssl-use-sys --shared-zlib || die
+}
+
+src_compile() {
+ emake out/Makefile
+ emake -C out mksnapshot
+ pax-mark m out/Release/mksnapshot
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${ED}"
+
+ dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}