summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-04-16 22:28:42 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-04-16 22:28:42 +0000
commitda40b04652ee0e095fc6317c577787a41c5294f8 (patch)
tree4fed3ea455b56eb1b0175248d9de9f26544f47cb /net-libs
parentDrop USE=wifi mask since it works on mips. (diff)
downloadgentoo-2-da40b04652ee0e095fc6317c577787a41c5294f8.tar.gz
gentoo-2-da40b04652ee0e095fc6317c577787a41c5294f8.tar.bz2
gentoo-2-da40b04652ee0e095fc6317c577787a41c5294f8.zip
Add new snapshot with python3 support.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/stem/ChangeLog9
-rw-r--r--net-libs/stem/stem-1.3.0_p20150414.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/net-libs/stem/ChangeLog b/net-libs/stem/ChangeLog
index d53898f26d66..c722f1aa5772 100644
--- a/net-libs/stem/ChangeLog
+++ b/net-libs/stem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/stem
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/stem/ChangeLog,v 1.9 2014/12/22 22:43:08 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/stem/ChangeLog,v 1.10 2015/04/16 22:28:42 mrueg Exp $
+
+*stem-1.3.0_p20150414 (16 Apr 2015)
+
+ 16 Apr 2015; Manuel Rüger <mrueg@gentoo.org> +stem-1.3.0_p20150414.ebuild:
+ Add new snapshot with python3 support.
*stem-1.3.0 (22 Dec 2014)
diff --git a/net-libs/stem/stem-1.3.0_p20150414.ebuild b/net-libs/stem/stem-1.3.0_p20150414.ebuild
new file mode 100644
index 000000000000..d96cf66d5d00
--- /dev/null
+++ b/net-libs/stem/stem-1.3.0_p20150414.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/stem/stem-1.3.0_p20150414.ebuild,v 1.1 2015/04/16 22:28:42 mrueg Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+COMMIT_ID="f2eca8fe828d965a86b8789e9d6049c424452ac7"
+SRC_URI="https://gitweb.torproject.org/stem.git/snapshot/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-misc/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-misc/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_get_connections_by_ss/,+1d"\
+ test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}