summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-07-19 06:52:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-07-19 06:52:01 +0000
commitdb78e5d279629a0e98c4324831844a967187ed63 (patch)
tree802c20828d769f895e243fa7a708964fdea4bc13 /net-libs
parentVersion bump. Drop ruby18, no longer compatible. (diff)
downloadgentoo-2-db78e5d279629a0e98c4324831844a967187ed63.tar.gz
gentoo-2-db78e5d279629a0e98c4324831844a967187ed63.tar.bz2
gentoo-2-db78e5d279629a0e98c4324831844a967187ed63.zip
Bump for #477348 with jbergstroem's patches for #475354
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/ChangeLog9
-rw-r--r--net-libs/nodejs/metadata.xml3
-rw-r--r--net-libs/nodejs/nodejs-0.10.13.ebuild68
-rw-r--r--net-libs/nodejs/nodejs-0.11.4.ebuild84
4 files changed, 163 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index 4c7f92256bce..c0310eba589e 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.93 2013/06/26 11:58:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.94 2013/07/19 06:52:01 patrick Exp $
+
+*nodejs-0.11.4 (19 Jul 2013)
+*nodejs-0.10.13 (19 Jul 2013)
+
+ 19 Jul 2013; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.13.ebuild,
+ +nodejs-0.11.4.ebuild, metadata.xml:
+ Bump for #477348 with jbergstroem's patches for #475354
26 Jun 2013; Agostino Sarubbo <ago@gentoo.org> nodejs-0.10.7.ebuild:
Stable for arm, wrt bug #473802
diff --git a/net-libs/nodejs/metadata.xml b/net-libs/nodejs/metadata.xml
index 7f74d66e6f3f..d30ceae9b2c5 100644
--- a/net-libs/nodejs/metadata.xml
+++ b/net-libs/nodejs/metadata.xml
@@ -10,4 +10,7 @@
<email>patrick@gentoo.org</email>
<name>Patrick Lauer</name>
</maintainer>
+ <use>
+ <flag name='npm'>Enable NPM package manager</flag>
+ </use>
</pkgmetadata>
diff --git a/net-libs/nodejs/nodejs-0.10.13.ebuild b/net-libs/nodejs/nodejs-0.10.13.ebuild
new file mode 100644
index 000000000000..35116db8d0cc
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.10.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.13.ebuild,v 1.1 2013/07/19 06:52:01 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/python-json"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ emake out/Makefile
+ emake -C out mksnapshot
+ pax-mark m out/Release/mksnapshot
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}"
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}
diff --git a/net-libs/nodejs/nodejs-0.11.4.ebuild b/net-libs/nodejs/nodejs-0.11.4.ebuild
new file mode 100644
index 000000000000..7914aaa88b7b
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.11.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.11.4.ebuild,v 1.1 2013/07/19 06:52:01 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+
+ # Use target arch detection logic, see v8-3.18 ebuilds
+ case ${CHOST} in
+ i?86-*)
+ myarch="ia32"
+ myconf+=" -Dv8_target_arch=ia32" ;;
+ x86_64-*)
+ if [[ $ABI = x86 ]] ; then
+ myarch="ia32"
+ else
+ myarch="x64"
+ fi ;;
+ arm*-*)
+ myarch="arm"
+ ;;
+ *) die "Unrecognized CHOST: ${CHOST}"
+ esac
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ emake out/Makefile
+ emake -C out "mksnapshot.${myarch}"
+ pax-mark m "out/Release/mksnapshot.${myarch}"
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}" /usr
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}