summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-08-25 21:17:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-08-25 21:17:57 +0000
commit0a9ad20d7cc538a4203fcd13c7be648e0987a8bd (patch)
tree02996c785283a9b357252e7178410027e1d19b98 /net-mail/courier-imap/courier-imap-4.0.4.ebuild
parentVersion bump. Fixes bug #144436. Thanks to abhay for reporting. (diff)
downloadgentoo-2-0a9ad20d7cc538a4203fcd13c7be648e0987a8bd.tar.gz
gentoo-2-0a9ad20d7cc538a4203fcd13c7be648e0987a8bd.tar.bz2
gentoo-2-0a9ad20d7cc538a4203fcd13c7be648e0987a8bd.zip
Add chown fixup to avoid some user weirdness of perms 600 on a directory.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'net-mail/courier-imap/courier-imap-4.0.4.ebuild')
-rw-r--r--net-mail/courier-imap/courier-imap-4.0.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-mail/courier-imap/courier-imap-4.0.4.ebuild b/net-mail/courier-imap/courier-imap-4.0.4.ebuild
index e0afecc3d4c3..f2fe2973032f 100644
--- a/net-mail/courier-imap/courier-imap-4.0.4.ebuild
+++ b/net-mail/courier-imap/courier-imap-4.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/courier-imap-4.0.4.ebuild,v 1.10 2006/08/18 21:20:03 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/courier-imap-4.0.4.ebuild,v 1.11 2006/08/25 21:17:57 robbat2 Exp $
inherit eutils gnuconfig
IUSE="fam berkdb gdbm debug ipv6 nls selinux"
@@ -301,6 +301,9 @@ pkg_postinst() {
einfo "athentication libraries are from courier-authlib"
einfo "for a quick start please refer to"
einfo "/usr/share/doc/${P}/courier-imap-gentoo.readme.gz"
+ # some users have been reporting that permissions on this directory were getting
+ # scrambled, so let's ensure that they are sane.
+ chmod 755 ${ROOT}/usr/$(get_libdir)/courier-imap || die "Failed to ensure sane permissions"
}
src_test() {