summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-02-18 18:39:03 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-02-18 18:39:03 +0000
commit4a3a57d1efbb50283beca4a6afbb13e1845efc0b (patch)
tree381564bc841b031967077191377ee05d508120c1 /net-mail/fetchmail
parentStable on ppc64 (diff)
downloadgentoo-2-4a3a57d1efbb50283beca4a6afbb13e1845efc0b.tar.gz
gentoo-2-4a3a57d1efbb50283beca4a6afbb13e1845efc0b.tar.bz2
gentoo-2-4a3a57d1efbb50283beca4a6afbb13e1845efc0b.zip
Version bump. Should fix bug #163782, reported upstream as #10133.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog7
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.7.ebuild82
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.3.73
3 files changed, 91 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index b4c81b0b7f57..c059ea21e9c7 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.125 2007/01/20 18:29:59 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.126 2007/02/18 18:39:03 ticho Exp $
+
+*fetchmail-6.3.7 (18 Feb 2007)
+
+ 18 Feb 2007; Andrej Kacian <ticho@gentoo.org> +fetchmail-6.3.7.ebuild:
+ Version bump. Should fix bug #163782, reported upstream as #10133.
20 Jan 2007; Alexander H. Færøy <eroyf@gentoo.org>
fetchmail-6.3.6.ebuild:
diff --git a/net-mail/fetchmail/fetchmail-6.3.7.ebuild b/net-mail/fetchmail/fetchmail-6.3.7.ebuild
new file mode 100644
index 000000000000..46ad79940e67
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.7.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.7.ebuild,v 1.1 2007/02/18 18:39:03 ticho Exp $
+
+inherit eutils
+
+FCONF_P="fetchmailconf-1.43.2"
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="http://download2.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl nls ipv6 kerberos krb4 hesiod"
+
+DEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( app-crypt/mit-krb5 )
+ nls? ( sys-devel/gettext )
+ elibc_FreeBSD? ( sys-libs/com_err )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # this patch fixes bug #34788 (ticho@gentoo.org 2004-09-03)
+ epatch "${FILESDIR}"/${PN}-6.2.5-broken-headers.patch || die
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_enable ipv6 inet6) \
+ $(use_with kerberos gssapi) $(use_with kerberos kerberos5) \
+ $(use_with krb4 kerberos) \
+ $(use_with ssl) \
+ $(use_with hesiod) \
+ ${myconf} || die "Configuration failed."
+ # wont compile reliably on smp (mkennedy@gentoo.org 2003-11-12)
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README README.NTLM README.SSL TODO
+
+ newinitd ${FILESDIR}/fetchmail fetchmail
+ newconfd ${FILESDIR}/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Add 'tk' to the USE variable in /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+ einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+ einfo "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.3.7 b/net-mail/fetchmail/files/digest-fetchmail-6.3.7
new file mode 100644
index 000000000000..7503a236c11c
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.3.7
@@ -0,0 +1,3 @@
+MD5 9ef60ab06661108c3c6605aad97e8325 fetchmail-6.3.7.tar.bz2 1315062
+RMD160 95b06b5e014c89416269dbc762c8556b20ce74ad fetchmail-6.3.7.tar.bz2 1315062
+SHA256 7957f5eaf4aca6d839ca9869f607b005d09ded884774b8757693410b492ce9f3 fetchmail-6.3.7.tar.bz2 1315062