summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-11 22:06:52 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-11 22:06:52 +0000
commitdb70da22458ca571213eb1ee256096f563dc9bef (patch)
treea847ec81a4826d5c0a454712772e4ac12ed8bbe8 /net-mail/fetchmail
parentNew qmail ebuild! Added tls, smtp-auth, and ldap support. ldap and tls (diff)
downloadgentoo-2-db70da22458ca571213eb1ee256096f563dc9bef.tar.gz
gentoo-2-db70da22458ca571213eb1ee256096f563dc9bef.tar.bz2
gentoo-2-db70da22458ca571213eb1ee256096f563dc9bef.zip
Version bump. Fixed configure scripts so gcc3 doesn't complain about
-I/usr/include being specified. Fixed ebuild problems as mentioned in bug #7338. Changed to econf and einstall.
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/fetchmail-5.9.14.ebuild82
-rw-r--r--net-mail/fetchmail/files/configure-5.9.14.diff66
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-5.9.141
3 files changed, 149 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-5.9.14.ebuild b/net-mail/fetchmail/fetchmail-5.9.14.ebuild
new file mode 100644
index 000000000000..af564377b90a
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-5.9.14.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.9.14.ebuild,v 1.1 2002/09/11 22:06:52 raker Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 sparc sparc64"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/configure-5.9.14.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ # This needs inet6-apps, which we don't have
+ #use ipv6 && myconf="{myconf} --enable-inet6"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+
+}
+
+src_install() {
+
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+}
diff --git a/net-mail/fetchmail/files/configure-5.9.14.diff b/net-mail/fetchmail/files/configure-5.9.14.diff
new file mode 100644
index 000000000000..3847ca4e80c5
--- /dev/null
+++ b/net-mail/fetchmail/files/configure-5.9.14.diff
@@ -0,0 +1,66 @@
+diff -urN fetchmail-5.9.14/configure fetchmail-5.9.14-modified/configure
+--- fetchmail-5.9.14/configure Wed Sep 4 08:43:37 2002
++++ fetchmail-5.9.14-modified/configure Wed Sep 11 16:57:12 2002
+@@ -6949,7 +6949,7 @@
+ #define KERBEROS_V5 1
+ EOF
+
+- test "$dir" != "/usr" && CEFLAGS="$CEFLAGS -I$dir/include"
++ test "$dir" != "/usr" && CEFLAGS="$CEFLAGS"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
+ LIBS="$LIBS $ac_krblibs $libk5crypto"
+ with_kerberos5=$dir
+@@ -7259,7 +7259,7 @@
+ then
+ ### ssl.h found under openssl. Use openssl configuration preferentially
+ echo "Enabling OpenSSL support in $with_ssl"
+- CEFLAGS="$CEFLAGS -I$with_ssl/include -I$with_ssl/include/openssl"
++ CEFLAGS="$CEFLAGS -I$with_ssl/include/openssl"
+ ### OpenBSD comes with ssl headers
+ elif test -r /usr/include/ssl/ssl.h
+ then
+@@ -7267,7 +7267,7 @@
+ CEFLAGS="$CEFLAGS -I/usr/include/ssl"
+ else
+ echo "Enabling SSLeay support in $with_ssl"
+- CEFLAGS="$CEFLAGS -I$with_ssl/include"
++ CEFLAGS="$CEFLAGS"
+ fi
+ LDEFLAGS="$LDEFLAGS -L$with_ssl/lib"
+ LIBS="$LIBS -lssl -lcrypto"
+@@ -7484,7 +7484,7 @@
+ do
+ if test -f "$dir/include/hesiod.h"
+ then
+- CEFLAGS="$CEFLAGS -DHESIOD -I$dir/include"
++ CEFLAGS="$CEFLAGS -DHESIOD"
+ LDEFLAGS="$LDEFLAGS -L$dir/lib"
+ LIBS="$LIBS -lhesiod"
+ with_hesiod=$dir
+@@ -7494,7 +7494,7 @@
+ ;;
+ *)
+ # Path given
+- CEFLAGS="$CEFLAGS -DHESIOD -I$with_hesiod/include"
++ CEFLAGS="$CEFLAGS -DHESIOD"
+ LDEFLAGS="$LDEFLAGS -L$with_hesiod/lib"
+ LIBS="$LIBS -lhesiod"
+ ;;
+@@ -7513,7 +7513,7 @@
+ fi
+ if test "$with_gssapi" != "yes" -a -n "$with_gssapi"
+ then
+- CFLAGS="$CFLAGS -I$with_gssapi/include"
++ CFLAGS="$CFLAGS"
+ LDFLAGS="$LDFLAGS -L$with_gssapi/lib"
+ fi
+
+@@ -7613,7 +7613,7 @@
+ EOF
+
+ save_CPPFLAGS=$CPPFLAGS
+- CPPFLAGS="-I$with_gssapi/include"
++ CPPFLAGS=""
+ for ac_hdr in gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h
+ do
+ ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
diff --git a/net-mail/fetchmail/files/digest-fetchmail-5.9.14 b/net-mail/fetchmail/files/digest-fetchmail-5.9.14
new file mode 100644
index 000000000000..e9097dcbecfa
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-5.9.14
@@ -0,0 +1 @@
+MD5 c8a9b828e734723ff48e79246aef92f4 fetchmail-5.9.14.tar.gz 984070