summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-10-02 21:26:55 +0000
committerAron Griffis <agriffis@gentoo.org>2006-10-02 21:26:55 +0000
commitcd4446bb75baa2fd9a95cd72d470180dfdfe54c1 (patch)
tree0a95cda032909faef5212140e745a1d9d8b825c7 /net-mail/gnubiff
parentBlock on older ant-tasks to prevent breakages during update, solves bug #149661. (diff)
downloadgentoo-2-cd4446bb75baa2fd9a95cd72d470180dfdfe54c1.tar.gz
gentoo-2-cd4446bb75baa2fd9a95cd72d470180dfdfe54c1.tar.bz2
gentoo-2-cd4446bb75baa2fd9a95cd72d470180dfdfe54c1.zip
Bump to 2.2.2 (from 2.2.1)
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-mail/gnubiff')
-rw-r--r--net-mail/gnubiff/ChangeLog7
-rw-r--r--net-mail/gnubiff/files/digest-gnubiff-2.2.23
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.2.ebuild43
3 files changed, 52 insertions, 1 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index ccb024d19365..74255f67e8b8 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/gnubiff
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.12 2006/10/02 21:23:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.13 2006/10/02 21:26:55 agriffis Exp $
+
+*gnubiff-2.2.2 (02 Oct 2006)
+
+ 02 Oct 2006; Aron Griffis <agriffis@gentoo.org> +gnubiff-2.2.2.ebuild:
+ Bump to 2.2.2 (from 2.2.1)
02 Oct 2006; Aron Griffis <agriffis@gentoo.org> gnubiff-2.1.9.ebuild:
Update 2.1.9 ebuild to include fixes from 2.2.1 ebuild, and fix
diff --git a/net-mail/gnubiff/files/digest-gnubiff-2.2.2 b/net-mail/gnubiff/files/digest-gnubiff-2.2.2
new file mode 100644
index 000000000000..775787cb2047
--- /dev/null
+++ b/net-mail/gnubiff/files/digest-gnubiff-2.2.2
@@ -0,0 +1,3 @@
+MD5 54e026ed12571350dcf8965a090dfa45 gnubiff-2.2.2.tar.gz 812648
+RMD160 fe59f5cac7e14fe1ce95db686d3df32097a221cd gnubiff-2.2.2.tar.gz 812648
+SHA256 120b6f1486f5c78df7fc3190ac1d19151f603261d2afd9e2c97a5c7eb4575306 gnubiff-2.2.2.tar.gz 812648
diff --git a/net-mail/gnubiff/gnubiff-2.2.2.ebuild b/net-mail/gnubiff/gnubiff-2.2.2.ebuild
new file mode 100644
index 000000000000..79be66cd3db9
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.2.ebuild,v 1.1 2006/10/02 21:26:55 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="debug fam gnome nls password"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ gnome? (
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2 )
+ password? ( dev-libs/openssl )
+ fam? ( virtual/fam )
+ || (
+ x11-proto/xproto
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ gnome? ( dev-util/pkgconfig )"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable gnome) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM}) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README THANKS TODO
+}