summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-01-09 09:43:09 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-01-09 09:43:09 +0000
commit13efddb1b1d31aeee124b380a7e61a1a5b04a0e4 (patch)
tree81cee2509918e38ebf41997bc729e5f38d58fd24 /net-mail/mairix/mairix-0.17.1.ebuild
parentAdd description to metadata.xml. Mark 1.1.33 stable on x86. Version bump. (diff)
downloadgentoo-2-13efddb1b1d31aeee124b380a7e61a1a5b04a0e4.tar.gz
gentoo-2-13efddb1b1d31aeee124b380a7e61a1a5b04a0e4.tar.bz2
gentoo-2-13efddb1b1d31aeee124b380a7e61a1a5b04a0e4.zip
Version bump. 0.17 stable on x86.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-mail/mairix/mairix-0.17.1.ebuild')
-rw-r--r--net-mail/mairix/mairix-0.17.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/mairix/mairix-0.17.1.ebuild b/net-mail/mairix/mairix-0.17.1.ebuild
new file mode 100644
index 000000000000..f8f4c2251728
--- /dev/null
+++ b/net-mail/mairix/mairix-0.17.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mairix/mairix-0.17.1.ebuild,v 1.1 2006/01/09 09:43:09 ticho Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Indexes and searches Maildir/MH folders"
+HOMEPAGE="http://www.rpcurnow.force9.co.uk/mairix/"
+SRC_URI="http://www.rpcurnow.force9.co.uk/mairix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ >=sys-apps/texinfo-4.2"
+
+src_unpack() {
+ unpack ${A}
+
+ # econf would fail with unknown options.
+ # Now it only prints "Unrecognized option".
+ sed -i -e "/^[[:space:]]*bad_options=yes/d" "${S}"/configure || die "sed failed."
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf || die "configure failed."
+
+ emake all mairix.info || die "make failed."
+}
+
+src_install() {
+ dobin mairix || die "dobin failed"
+ doinfo mairix.info
+ dodoc NEWS README mairix.txt
+}