summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-06-06 18:01:35 +0000
committerEray Aslan <eras@gentoo.org>2011-06-06 18:01:35 +0000
commit8dc167ce07604fce447672d42dcb8048e1ca2977 (patch)
tree80f9fc934e5e00aa07f94a16154f8c6cb71f96ac /net-mail/mboxgrep
parentSync kde eclasses from overlay (diff)
downloadgentoo-2-8dc167ce07604fce447672d42dcb8048e1ca2977.tar.gz
gentoo-2-8dc167ce07604fce447672d42dcb8048e1ca2977.tar.bz2
gentoo-2-8dc167ce07604fce447672d42dcb8048e1ca2977.zip
Respect LDFLAGS - bug #337442. Do not strip - bug #240926. Fix implicit declarations.
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/mboxgrep')
-rw-r--r--net-mail/mboxgrep/ChangeLog11
-rw-r--r--net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch52
-rw-r--r--net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild32
3 files changed, 93 insertions, 2 deletions
diff --git a/net-mail/mboxgrep/ChangeLog b/net-mail/mboxgrep/ChangeLog
index 8012afda455f..977b5ba0a329 100644
--- a/net-mail/mboxgrep/ChangeLog
+++ b/net-mail/mboxgrep/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/mboxgrep
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mboxgrep/ChangeLog,v 1.14 2009/09/23 19:08:03 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mboxgrep/ChangeLog,v 1.15 2011/06/06 18:01:34 eras Exp $
+
+*mboxgrep-0.7.9-r1 (06 Jun 2011)
+
+ 06 Jun 2011; Eray Aslan <eras@gentoo.org> +mboxgrep-0.7.9-r1.ebuild,
+ +files/mboxgrep-0.7.9-ldflags.patch:
+ Respect LDFLAGS - bug #337442. Do not strip - bug #240926. Fix implicit
+ declarations.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> mboxgrep-0.7.9.ebuild:
Remove virtual/libc
diff --git a/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch b/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch
new file mode 100644
index 000000000000..dd0742626b47
--- /dev/null
+++ b/net-mail/mboxgrep/files/mboxgrep-0.7.9-ldflags.patch
@@ -0,0 +1,52 @@
+commit f51a9eafb80a5c5e506d7fe416c0b768ec1a6655
+Author: Eray Aslan <eras@gentoo.org>
+Date: Mon Jun 6 20:11:32 2011 +0300
+
+ Respect LDFLAGS and do not strip
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index fc5ac74..2b89866 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -39,7 +39,7 @@ INCLUDES = -I. -I$(srcdir)
+ $(CC) $(CFLAGS) $(INCLUDES) -c $<
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ .PHONY: clean
+ clean:
+@@ -52,6 +52,6 @@ distclean:
+ .PHONY: install
+ install: mboxgrep
+ $(INSTALL) -d $(prefix)/bin
+- $(INSTALL) -s $(TARGET) $(prefix)/bin
++ $(INSTALL) $(TARGET) $(prefix)/bin
+
+ .NOEXPORT:
+commit 1a0a345ad4c38df41227e3f2600bcf05ed49bbd7
+Author: Eray Aslan <eras@gentoo.org>
+Date: Mon Jun 6 20:52:06 2011 +0300
+
+ everyone has standard C headers nowadays
+
+diff --git a/src/md5.c b/src/md5.c
+index d6b8013..a797552 100644
+--- a/src/md5.c
++++ b/src/md5.c
+@@ -26,14 +26,8 @@
+
+ #include <sys/types.h>
+
+-#if STDC_HEADERS || defined _LIBC
+ # include <stdlib.h>
+ # include <string.h>
+-#else
+-# ifndef HAVE_MEMCPY
+-# define memcpy(d, s, n) bcopy ((s), (d), (n))
+-# endif
+-#endif
+
+ #include "md5.h"
+
diff --git a/net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild b/net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild
new file mode 100644
index 000000000000..52267fc21bc8
--- /dev/null
+++ b/net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mboxgrep/mboxgrep-0.7.9-r1.ebuild,v 1.1 2011/06/06 18:01:34 eras Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Grep for mbox files"
+SRC_URI="mirror://sourceforge/mboxgrep/${P}.tar.gz"
+HOMEPAGE="http://mboxgrep.sf.net"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_install () {
+ emake \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install
+ dodoc ChangeLog NEWS TODO README
+}