summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2003-08-01 08:21:04 +0000
committerBrad Laue <brad@gentoo.org>2003-08-01 08:21:04 +0000
commita3d7618b69946efcdcfff0a50827cf061fd79abc (patch)
tree04a4e947a4e3282a3846506c4de2d9fa5f35e20c /net-mail/mozilla-thunderbird
parentActually unzip the proper tarball. (diff)
downloadgentoo-2-a3d7618b69946efcdcfff0a50827cf061fd79abc.tar.gz
gentoo-2-a3d7618b69946efcdcfff0a50827cf061fd79abc.tar.bz2
gentoo-2-a3d7618b69946efcdcfff0a50827cf061fd79abc.zip
GNOME icon function in the right place, commented for now
Diffstat (limited to 'net-mail/mozilla-thunderbird')
-rw-r--r--net-mail/mozilla-thunderbird/mozilla-thunderbird-0.1_alpha20030727.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.1_alpha20030727.ebuild b/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.1_alpha20030727.ebuild
index a263847274c6..e6a17bdc6d1e 100644
--- a/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.1_alpha20030727.ebuild
+++ b/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.1_alpha20030727.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.1_alpha20030727.ebuild,v 1.2 2003/08/01 08:18:29 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.1_alpha20030727.ebuild,v 1.3 2003/08/01 08:21:04 brad Exp $
inherit makeedit flag-o-matic gcc nsplugins
@@ -124,6 +124,19 @@ src_compile() {
edit_makefiles
emake MOZ_THUNDERBIRD=1 || die
+}
+
+src_install() {
+
+ dodir /usr/lib
+ dodir /usr/lib/MozillaThunderbird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaThunderbird
+
+ #fix permissions
+ chown -R root.root ${D}/usr/lib/MozillaThunderbird
+
+ dobin ${FILESDIR}/MozillaThunderbird
+
# # Install icon and .desktop for menu entry
# if [ "`use gnome`" ]
# then
@@ -143,15 +156,3 @@ src_compile() {
}
-src_install() {
-
- dodir /usr/lib
- dodir /usr/lib/MozillaThunderbird
- cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaThunderbird
-
- #fix permissions
- chown -R root.root ${D}/usr/lib/MozillaThunderbird
-
- dobin ${FILESDIR}/MozillaThunderbird
-}
-