summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-05-16 21:40:18 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-05-16 21:40:18 +0000
commita2d1380c09b7c4e19d07266e03bd85e98e8b5daa (patch)
treebb40a83ebf7956d404800dfca88a8f5fc880d66f /net-mail/notmuch
parentFix tests on pypy, remove test that accesses the network (bug #339252). (diff)
downloadgentoo-2-a2d1380c09b7c4e19d07266e03bd85e98e8b5daa.tar.gz
gentoo-2-a2d1380c09b7c4e19d07266e03bd85e98e8b5daa.tar.bz2
gentoo-2-a2d1380c09b7c4e19d07266e03bd85e98e8b5daa.zip
Version bump.
(Portage version: 2.1.10.59/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/ChangeLog30
-rw-r--r--net-mail/notmuch/metadata.xml1
-rw-r--r--net-mail/notmuch/notmuch-0.13.ebuild174
3 files changed, 204 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index 4b39ccfe2de7..4d45c8332437 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,34 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.52 2012/05/03 04:18:37 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.53 2012/05/16 21:40:18 aidecoe Exp $
+
+*notmuch-0.13 (16 May 2012)
+
+ 16 May 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +notmuch-0.13.ebuild,
+ metadata.xml:
+ Version bump.
+
+ NEWS
+ ~~~~
+ (Extracted headlines from NEWS file. See it for details.)
+
+ Command-Line Interface
+ - JSON reply format
+ - Tag exclusion (as an option in the config file)
+ - Raw show format changes
+ - Listing configuration items (new "config list" command)
+
+ Emacs Interface
+ - Changes to tagging interface (breaks compatibility with old tagging
+ functions)
+ - Reply improvement using the JSON format
+
+ New add-on tool: notmuch-mutt
+
+ Library changes
+
+ The API changes break binary and source compatibility, so libnotmuch has been
+ bumped to version 3.0.0.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> notmuch-0.10.2-r3.ebuild,
notmuch-0.11.1-r3.ebuild, notmuch-0.12.ebuild:
diff --git a/net-mail/notmuch/metadata.xml b/net-mail/notmuch/metadata.xml
index f6acb7d04b1b..d2ae0c0c0868 100644
--- a/net-mail/notmuch/metadata.xml
+++ b/net-mail/notmuch/metadata.xml
@@ -10,6 +10,7 @@
<flag name="crypt">Support decryption and verification of PGP/MIME
messages and in Emacs UI - encryption</flag>
<flag name="emacs">Install Notmuch client for Emacs (main client)</flag>
+ <flag name="mutt">Install helper script for Mutt</flag>
<flag name="nmbug">Install Experimental Tag Sharing /
Pseudo-Bug-Tracking for Notmuch
(http://notmuchmail.org/nmbug/)</flag>
diff --git a/net-mail/notmuch/notmuch-0.13.ebuild b/net-mail/notmuch/notmuch-0.13.ebuild
new file mode 100644
index 000000000000..1b69da6d32aa
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.13.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.13.ebuild,v 1.1 2012/05/16 21:40:18 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.1"
+
+inherit elisp-common pax-utils distutils
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="test? ( crypt emacs python )"
+IUSE="bash-completion crypt debug doc emacs nmbug mutt python test vim
+ zsh-completion"
+
+CDEPEND="
+ >=dev-libs/glib-2.22
+ >=dev-libs/gmime-2.6.7
+ dev-libs/xapian
+ doc? ( python? ( dev-python/sphinx ) )
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ vim? ( || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 ) )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ test? ( app-misc/dtach sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git virtual/perl-File-Temp virtual/perl-PodParser )
+ mutt? ( dev-perl/Mail-Box dev-perl/MailTools dev-perl/String-ShellQuote
+ dev-perl/Term-ReadLine-Gnu virtual/perl-File-Path
+ virtual/perl-Getopt-Long virtual/perl-PodParser
+ )
+ zsh-completion? ( app-shells/zsh )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+
+bindings() {
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ $@
+ popd || die
+ fi
+}
+
+nm_mutt() {
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ $@
+ popd || die
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ default
+ bindings python distutils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${ROOT}/usr/share/bash-completion"
+ --emacslispdir="${ROOT}/${SITELISP}/${PN}"
+ --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
+ --with-gmime-version=2.6
+ --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
+ $(use_with bash-completion)
+ $(use_with emacs)
+ $(use_with zsh-completion)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ bindings python distutils_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ mv README README-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ mv README README-python || die
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin contrib/nmbug
+ fi
+
+ if use mutt; then
+ [[ -e /etc/mutt/notmuch-mutt.rc ]] && NOTMUCH_MUTT_RC_EXISTS=1
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/plugin vim/syntax
+ fi
+
+ DOCS="" bindings python distutils_src_install
+
+ if use doc; then
+ bindings python dohtml -r python
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postinst
+
+ if use mutt && [[ ! ${NOTMUCH_MUTT_RC_EXISTS} ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postrm
+}