summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-12 22:30:00 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-12 22:30:00 +0000
commitac54707192f1c9db4cd26994ba5c45cf58b3582a (patch)
treeb5c89d43491f724b1d02f5f68ee9f7f37a03a3ac /net-mail/pine
parentportage-2.0.46-r6 added (diff)
downloadgentoo-2-ac54707192f1c9db4cd26994ba5c45cf58b3582a.tar.gz
gentoo-2-ac54707192f1c9db4cd26994ba5c45cf58b3582a.tar.bz2
gentoo-2-ac54707192f1c9db4cd26994ba5c45cf58b3582a.zip
New version of pine + some of the chappa patches
Diffstat (limited to 'net-mail/pine')
-rw-r--r--net-mail/pine/ChangeLog9
-rw-r--r--net-mail/pine/files/digest-pine-4.5211
-rw-r--r--net-mail/pine/pine-4.52.ebuild160
3 files changed, 179 insertions, 1 deletions
diff --git a/net-mail/pine/ChangeLog b/net-mail/pine/ChangeLog
index e8d77fc4103e..baa787a5a278 100644
--- a/net-mail/pine/ChangeLog
+++ b/net-mail/pine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/pine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.18 2003/01/03 20:05:51 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.19 2003/01/12 22:30:00 raker Exp $
+
+*pine-4.52 (12 Jan 2003)
+
+ 12 Jan 2003; Nick Hadaway <raker@gentoo.org> pine-4.52.ebuild,
+ files/digest-pine-4.52 :
+ Another version bump. A hand picked group of patches from the chappa
+ collection.
*pine-4.51 (03 Jan 2002)
diff --git a/net-mail/pine/files/digest-pine-4.52 b/net-mail/pine/files/digest-pine-4.52
new file mode 100644
index 000000000000..9867d03e42c5
--- /dev/null
+++ b/net-mail/pine/files/digest-pine-4.52
@@ -0,0 +1,11 @@
+MD5 cbdd475ebe0cb712350e3cb15643ecea pine4.52.tar.bz2 2804070
+MD5 f5b8cf2e5165d7f4fef26354e8a42bb3 fancy.patch.gz 23702
+MD5 9516e76eb29995506632d691fb06cd55 fillpara.patch.gz 8138
+MD5 9a4087027d9bd36744865a10e6f21140 outgoing.patch.gz 6331
+MD5 959aec36a510b70cbcafb64b17a5c0c5 WrtAcc.patch.gz 2368
+MD5 4bf39601a45ce151715be8312a322cfe fromheader.patch.gz 1630
+MD5 ff16f4f5eb50d8d29ee7c078a845ffd6 newmessages.patch.gz 1140
+MD5 cf8e0626538233b5d4d3804b1ab774be reply.patch.gz 4072
+MD5 1ebd94f4ef16caf94e1c6de15a18d273 newsrc.patch.gz 3328
+MD5 d5672e487e8246a6b7bc0fb4a5b0c5b4 status.patch.gz 655
+MD5 3d55d4f995d7a55278d8f737fc2e751c insertpat.patch.gz 813
diff --git a/net-mail/pine/pine-4.52.ebuild b/net-mail/pine/pine-4.52.ebuild
new file mode 100644
index 000000000000..5b67d30c8463
--- /dev/null
+++ b/net-mail/pine/pine-4.52.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.52.ebuild,v 1.1 2003/01/12 22:30:00 raker Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+SRC_URI="ftp://ftp.cac.washington.edu/${PN}/${PN}${PV}.tar.bz2
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/fancy.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/fillpara.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/outgoing.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/WrtAcc.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/fromheader.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/newmessages.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/reply.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/newsrc.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/status.patch.gz
+ http://www.math.washington.edu/~chappa/pine/patches/pine4.52/insertpat.patch.gz"
+HOMEPAGE="http://www.washington.edu/pine/
+ http://www.math.washington.edu/~chappa/pine/patches/"
+
+SLOT="0"
+LICENSE="PICO"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="ssl ldap"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ net-www/lynx"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${PN}${PV}.tar.bz2
+ cd ${S}
+
+ # fancy threads patch for a collapsed/uncollapsed mbox view
+ epatch ${DISTDIR}/fancy.patch.gz || die
+
+ # a patch for a smarter indentation algorithim
+ epatch ${DISTDIR}/fillpara.patch.gz || die
+
+ # use pine from the commandline to send email
+ epatch ${DISTDIR}/outgoing.patch.gz || die
+
+ # adds the ability for you to write letter accents
+ epatch ${DISTDIR}/WrtAcc.patch.gz || die
+
+ # gives you the ability to change your From: header
+ epatch ${DISTDIR}/fromheader.patch.gz || die
+
+ # keeps your new messages count up to date
+ epatch ${DISTDIR}/newmessages.patch.gz || die
+
+ # more options available when replying to messages
+ epatch ${DISTDIR}/reply.patch.gz || die
+
+ # add the ability to have multiple news servers
+ epatch ${DISTDIR}/newsrc.patch.gz || die
+
+ # "actualizes" (updates) the status line as your current position changes
+ epatch ${DISTDIR}/status.patch.gz || die
+
+ # re-insert your last searched pattern
+ epatch ${DISTDIR}/insertpat.patch.gz || die
+
+ epatch ${FILESDIR}/pine-4.21-fixhome.patch
+
+ epatch ${FILESDIR}/imap-4.7c2-flock.patch
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+
+ if [ "`use ldap`" ] ; then
+ # link to shared ldap libs instead of static
+ epatch ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+
+ epatch ${FILESDIR}/pine-4.40-boguswarning.patch
+
+ epatch ${FILESDIR}/pine-4.31-segfix.patch
+
+ epatch ${FILESDIR}/pine-4.40-lockfile-perm.patch
+
+ epatch ${FILESDIR}/imap-2000-time.patch
+
+ epatch ${FILESDIR}/pine-4.33-whitespace.patch
+
+ if [ -n "$DEBUGBUILD" ]; then
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ < makefile.orig > makefile.lnx
+ else
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+ fi
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ cd ${S}/imap/src/osdep/unix
+ cp Makefile Makefile.orig
+ sed \
+ -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
+ -e "s:\$(SSLCERTS):/etc/ssl/certs:" \
+ -e "s:-I\$(SSLINCLUDE) ::" \
+ < Makefile.orig > Makefile
+ cd ${S}
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+ use mbox || dodoc README.maildir
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/FAQ imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}