summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-10-10 21:42:54 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-10-10 21:42:54 +0000
commitd04fd18c7b55b9994c36e452c76e461711086cc8 (patch)
tree6d8900beca4013e68085d8654d16b2cbc2cc1be3 /net-mail/sendEmail
parentship headers and build shared lib for mksquashfs and other things that dep on... (diff)
downloadgentoo-2-d04fd18c7b55b9994c36e452c76e461711086cc8.tar.gz
gentoo-2-d04fd18c7b55b9994c36e452c76e461711086cc8.tar.bz2
gentoo-2-d04fd18c7b55b9994c36e452c76e461711086cc8.zip
More checks overtaken by events and no longer relevant. Identified & fixed by Peter Wilmott, closes bug #472380.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-mail/sendEmail')
-rw-r--r--net-mail/sendEmail/ChangeLog9
-rw-r--r--net-mail/sendEmail/files/1.56-overzealous-verify-mode-check.patch11
-rw-r--r--net-mail/sendEmail/sendEmail-1.56-r2.ebuild (renamed from net-mail/sendEmail/sendEmail-1.56.ebuild)17
3 files changed, 31 insertions, 6 deletions
diff --git a/net-mail/sendEmail/ChangeLog b/net-mail/sendEmail/ChangeLog
index 479086f457d3..3a6be3dbd5f2 100644
--- a/net-mail/sendEmail/ChangeLog
+++ b/net-mail/sendEmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/sendEmail
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sendEmail/ChangeLog,v 1.23 2013/04/05 21:49:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sendEmail/ChangeLog,v 1.24 2013/10/10 21:42:54 chainsaw Exp $
+
+*sendEmail-1.56-r2 (10 Oct 2013)
+
+ 10 Oct 2013; Tony Vroon <chainsaw@gentoo.org> -sendEmail-1.56.ebuild,
+ +sendEmail-1.56-r2.ebuild, +files/1.56-overzealous-verify-mode-check.patch:
+ More checks overtaken by events and no longer relevant. Identified & fixed by
+ Peter Wilmott, closes bug #472380.
05 Apr 2013; Agostino Sarubbo <ago@gentoo.org> sendEmail-1.56-r1.ebuild:
Stable for x86, wrt bug #464204
diff --git a/net-mail/sendEmail/files/1.56-overzealous-verify-mode-check.patch b/net-mail/sendEmail/files/1.56-overzealous-verify-mode-check.patch
new file mode 100644
index 000000000000..f5c5c39ee5c7
--- /dev/null
+++ b/net-mail/sendEmail/files/1.56-overzealous-verify-mode-check.patch
@@ -0,0 +1,11 @@
+--- sendEmail 2013-05-21 16:44:18.000000000 +0100
++++ sendEmail 2013-06-05 09:26:20.000000000 +0100
+@@ -1903,7 +1903,7 @@
+ if ($conf{'tls_server'} == 1 and $conf{'tls_client'} == 1 and $opt{'tls'} =~ /^(yes|auto)$/) {
+ printmsg("DEBUG => Starting TLS", 2);
+ if (SMTPchat('STARTTLS')) { quit($conf{'error'}, 1); }
+- if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'SSLv3')) {
++ if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'SSLv3', SSL_verify_mode => 0x00)) {
+ quit("ERROR => TLS setup failed: " . IO::Socket::SSL::errstr(), 1);
+ }
+ printmsg("DEBUG => TLS: Using cipher: ". $SERVER->get_cipher(), 3);
diff --git a/net-mail/sendEmail/sendEmail-1.56.ebuild b/net-mail/sendEmail/sendEmail-1.56-r2.ebuild
index e985243a8c9d..44dcffeb5d70 100644
--- a/net-mail/sendEmail/sendEmail-1.56.ebuild
+++ b/net-mail/sendEmail/sendEmail-1.56-r2.ebuild
@@ -1,21 +1,28 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sendEmail/sendEmail-1.56.ebuild,v 1.3 2011/11/28 11:32:36 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sendEmail/sendEmail-1.56-r2.ebuild,v 1.1 2013/10/10 21:42:54 chainsaw Exp $
+
+EAPI=5
+MY_P="${PN}-v${PV}"
+
+inherit base
DESCRIPTION="Command line based, SMTP email agent"
HOMEPAGE="http://caspian.dotconf.net/menu/Software/SendEmail/"
-SRC_URI="http://caspian.dotconf.net/menu/Software/SendEmail/${PN}-v${PV}.tar.gz"
+SRC_URI="http://caspian.dotconf.net/menu/Software/SendEmail/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="ssl"
DEPEND=""
RDEPEND="dev-lang/perl
ssl? ( dev-perl/IO-Socket-SSL )"
-S="${WORKDIR}/${PN}-v${PV}"
+PATCHES=( "${FILESDIR}/${PV}-overzealous-version-check.patch"
+ "${FILESDIR}/${PV}-overzealous-verify-mode-check.patch" )
+S="${WORKDIR}/${MY_P}"
src_install() {
dobin sendEmail || die "failed to install sendEmail script"