summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-12 14:54:16 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-12 14:54:16 +0000
commit63eb4a96d8e739af6b5c6aef50ac6595b8eb3309 (patch)
treee9f2b1038fc4cf073e3efd9d6fe7f4d45037f9c2 /net-mail/sylpheed
parentversion changes (diff)
downloadgentoo-2-63eb4a96d8e739af6b5c6aef50ac6595b8eb3309.tar.gz
gentoo-2-63eb4a96d8e739af6b5c6aef50ac6595b8eb3309.tar.bz2
gentoo-2-63eb4a96d8e739af6b5c6aef50ac6595b8eb3309.zip
version update
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/ChangeLog6
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.7.61
-rw-r--r--net-mail/sylpheed/sylpheed-0.7.6.ebuild49
3 files changed, 55 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index 65855d504077..0c825cd19b44 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.5 2002/04/23 02:24:08 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.6 2002/05/12 14:54:16 spider Exp $
+*sylpheed-0.7.6 (12 May 2002)
+ 12 May 2002; Spider <spider@gentoo.org> sylpheed-0.7.6.ebuild:
+ New upstream
+
*sylpheed-0.7.5 (22 Apr 2002)
22 Apr 2002; Jon Nelson <jnelson@gentoo.org> sylpheed-0.7.5.ebuild:
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.7.6 b/net-mail/sylpheed/files/digest-sylpheed-0.7.6
new file mode 100644
index 000000000000..1886b5fe4396
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.7.6
@@ -0,0 +1 @@
+MD5 eb1bc2b5740f6cad5bb69a489a5a2a24 sylpheed-0.7.6.tar.bz2 1731069
diff --git a/net-mail/sylpheed/sylpheed-0.7.6.ebuild b/net-mail/sylpheed/sylpheed-0.7.6.ebuild
new file mode 100644
index 000000000000..f401878026ff
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.7.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.7.6.ebuild,v 1.1 2002/05/12 14:54:16 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/sylpheed/sylpheed-${PV}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/compface-1.4
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+
+ local myconf
+
+ use gnome || myconf="--disable-gdk-pixbuf --disable-imlib"
+ use nls || myconf="$myconf --disable-nls"
+ use ssl && myconf="$myconf --enable-ssl"
+ use crypt && myconf="$myconf --enable-gpgme"
+ use pda && myconf="$myconf --enable-jpilot"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}
+