summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-06-04 22:05:18 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-06-04 22:05:18 +0000
commit91935548c0e58b89f3f49a107c49a088f442eeca (patch)
treec237ba71339429cd7b9206319356157e3ac26497 /net-mail/tmda
parentrelax DEPEND for db (diff)
downloadgentoo-2-91935548c0e58b89f3f49a107c49a088f442eeca.tar.gz
gentoo-2-91935548c0e58b89f3f49a107c49a088f442eeca.tar.bz2
gentoo-2-91935548c0e58b89f3f49a107c49a088f442eeca.zip
Version bump
Diffstat (limited to 'net-mail/tmda')
-rw-r--r--net-mail/tmda/ChangeLog7
-rw-r--r--net-mail/tmda/Manifest4
-rw-r--r--net-mail/tmda/files/digest-tmda-0.791
-rw-r--r--net-mail/tmda/tmda-0.79.ebuild58
4 files changed, 68 insertions, 2 deletions
diff --git a/net-mail/tmda/ChangeLog b/net-mail/tmda/ChangeLog
index 13accf83f3fa..20dc884cb654 100644
--- a/net-mail/tmda/ChangeLog
+++ b/net-mail/tmda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/tmda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.30 2003/04/14 18:46:22 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.31 2003/06/04 22:05:18 agenkin Exp $
+
+*tmda-0.79 (04 Jun 2003)
+
+ 04 Jun 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
*tmda-0.74 (14 Apr 2003)
diff --git a/net-mail/tmda/Manifest b/net-mail/tmda/Manifest
index d306be57a518..41f1fb2ca132 100644
--- a/net-mail/tmda/Manifest
+++ b/net-mail/tmda/Manifest
@@ -1,5 +1,7 @@
-MD5 ed9255e14afd4235a304bff511527043 ChangeLog 4861
MD5 e30e62156e0a084e16fe982be661812e tmda-0.65.ebuild 1352
+MD5 7b1d022a0369839f94ee0755b3960a2d tmda-0.79.ebuild 1558
+MD5 cd36e1469b572e53705c5a5518f7e59e ChangeLog 4956
MD5 7b1d022a0369839f94ee0755b3960a2d tmda-0.74.ebuild 1558
+MD5 991fd8624aa478637fdbd5882e2527ba files/digest-tmda-0.79 58
MD5 8ce39f234c191b0b501bedcfebabbc6d files/digest-tmda-0.65 58
MD5 585657593ed64b41a94dd019d5e5ef79 files/digest-tmda-0.74 58
diff --git a/net-mail/tmda/files/digest-tmda-0.79 b/net-mail/tmda/files/digest-tmda-0.79
new file mode 100644
index 000000000000..ca17c1bef22c
--- /dev/null
+++ b/net-mail/tmda/files/digest-tmda-0.79
@@ -0,0 +1 @@
+MD5 b9cf40339eca27b44ecbcb9fb6b3f377 tmda-0.79.tgz 311655
diff --git a/net-mail/tmda/tmda-0.79.ebuild b/net-mail/tmda/tmda-0.79.ebuild
new file mode 100644
index 000000000000..f6112c7c9960
--- /dev/null
+++ b/net-mail/tmda/tmda-0.79.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.79.ebuild,v 1.1 2003/06/04 22:05:18 agenkin Exp $
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.1
+ virtual/mta"
+
+SRC_URI="http://tmda.net/releases/${P}.tgz
+ http://tmda.net/releases/old/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+
+S="${WORKDIR}/${P}"
+
+src_compile () {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe collectaddys def2html getuserinfo-vpopmail.sh printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins ChangeLog sample.config tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+
+}