summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-06-03 14:39:01 +0000
committerEray Aslan <eras@gentoo.org>2011-06-03 14:39:01 +0000
commit20c2729a19728ef72cdd548d7999870911aed923 (patch)
tree0d45ec658814628813a4047d0ba3369230eefa4c /net-mail/tpop3d
parentDo not build test programs that are not really used, and cause underlinking f... (diff)
downloadgentoo-2-20c2729a19728ef72cdd548d7999870911aed923.tar.gz
gentoo-2-20c2729a19728ef72cdd548d7999870911aed923.tar.bz2
gentoo-2-20c2729a19728ef72cdd548d7999870911aed923.zip
Fix linking against gold - bug 369783. EAPI bump.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/tpop3d')
-rw-r--r--net-mail/tpop3d/ChangeLog10
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch20
-rw-r--r--net-mail/tpop3d/tpop3d-1.5.4-r3.ebuild97
3 files changed, 125 insertions, 2 deletions
diff --git a/net-mail/tpop3d/ChangeLog b/net-mail/tpop3d/ChangeLog
index bfa91436a3c3..5fd484dbdc57 100644
--- a/net-mail/tpop3d/ChangeLog
+++ b/net-mail/tpop3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/tpop3d
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.30 2010/08/09 08:40:25 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/ChangeLog,v 1.31 2011/06/03 14:39:00 eras Exp $
+
+*tpop3d-1.5.4-r3 (03 Jun 2011)
+
+ 03 Jun 2011; Eray Aslan <eras@gentoo.org> +tpop3d-1.5.4-r3.ebuild,
+ +files/tpop3d-1.5.4-gold.patch:
+ Fix linking against gold - bug 369783. EAPI bump.
09 Aug 2010; Peter Volkov <pva@gentoo.org> tpop3d-1.5.4-r2.ebuild,
metadata.xml:
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch b/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch
new file mode 100644
index 000000000000..149dc9430dd0
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch
@@ -0,0 +1,20 @@
+commit 8ed9a7721a406fea7dfc7f0a5eb6e68f3d63a99e
+Author: Eray Aslan <eras@gentoo.org>
+Date: Fri Jun 3 13:52:55 2011 +0000
+
+ Fix linking against gold
+
+diff --git a/configure.in b/configure.in
+index ac16864..a260652 100644
+--- a/configure.in
++++ b/configure.in
+@@ -587,7 +587,8 @@ fi
+ # OpenSSL
+ if test x"$enable_tls" = x"yes" || test x"$enable_sha1_passwords" = x"yes"
+ then
+- AC_CHECK_LIB2(ssl, SSL_new, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libssl]]), -lcrypto)
++ AC_CHECK_LIB(ssl, SSL_new, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libssl]]))
++ AC_CHECK_LIB(crypto, SHA1_Init, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libcrypto]]))
+ fi
+
+ # GNU dbm
diff --git a/net-mail/tpop3d/tpop3d-1.5.4-r3.ebuild b/net-mail/tpop3d/tpop3d-1.5.4-r3.ebuild
new file mode 100644
index 000000000000..f5295f134c8c
--- /dev/null
+++ b/net-mail/tpop3d/tpop3d-1.5.4-r3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.5.4-r3.ebuild,v 1.1 2011/06/03 14:39:01 eras Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An extensible POP3 server with vmail-sql/MySQL support."
+HOMEPAGE="http://savannah.nongnu.org/projects/tpop3d/"
+SRC_URI="http://download.savannah.nongnu.org/releases/tpop3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="authexternal debug drac flatfile gdbm ldap maildir mbox mysql offensive
+ pam passwd perl postgres +sha1 shadow ssl tcpd"
+
+RDEPEND="sha1? ( >=dev-libs/openssl-0.9.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-server )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ pam? ( virtual/pam
+ >=net-mail/mailbase-0.00-r8 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ drac? ( mail-client/drac )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gold.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+ local noauth=0
+
+ # Various authentication methods
+ use authexternal && myconf="${myconf} --enable-auth-other"
+ use flatfile && myconf="${myconf} --enable-auth-flatfile"
+ use gdbm && myconf="${myconf} --enable-auth-gdbm"
+ use ldap && myconf="${myconf} --enable-auth-ldap"
+ use mysql && myconf="${myconf} --enable-auth-mysql"
+ use pam || myconf="${myconf} --disable-auth-pam"
+ use passwd && myconf="${myconf} --enable-auth-passwd"
+ use perl && myconf="${myconf} --enable-auth-perl"
+ use postgres && myconf="${myconf} --enable-auth-pgsql"
+ use shadow && myconf="${myconf} --enable-auth-passwd --enable-shadow-passwords"
+
+ use authexternal || use flatfile || use gdbm || use ldap || use mysql ||
+ use pam || use passwd || use perl || use postgres || use shadow ||
+ noauth=1
+
+ if [[ ${noauth} -eq 1 ]]; then
+ ewarn "None of tpop3d's authentication mechanism USE flags are set."
+ ewarn "As a result tpop3d will be built with /etc/passwd authentication only."
+ myconf="${myconf} --enable-auth-passwd"
+ fi
+
+ # Other optional features
+ use debug && myconf="${myconf} --enable-backtrace"
+ use maildir && myconf="${myconf} --enable-mbox-maildir"
+ use mbox || myconf="${myconf} --disable-mbox-bsd"
+ use offensive || myconf="${myconf} --disable-snide-comments"
+ use sha1 || myconf="${myconf} --disable-sha1-passwords"
+ use ssl && myconf="${myconf} --enable-tls"
+ use tcpd && myconf="${myconf} --enable-tcp-wrappers"
+
+ # Install mail-client/drac for integration with tpop3d
+ use drac && myconf="${myconf} --enable-drac"
+
+ econf ${myconf}
+
+ # Causes crash with "stack smashing attack" on connect, because of bug in
+ # SSP (bug #115285)
+ filter-flags -fstack-protector
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodir /etc/tpop3d
+
+ if use pam ; then
+ dodir /etc/pam.d
+ dosym /etc/pam.d/pop3 /etc/pam.d/tpop3d
+ fi
+
+ newinitd "${FILESDIR}/${PN}-1.5.4.init" tpop3d
+}
+
+pkg_postinst() {
+ elog "Read the tpop3d.conf manpage"
+ elog "Please create /etc/tpop3d/tpop3d.conf to fit your configuration"
+}