summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-29 19:38:20 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-29 19:38:20 +0000
commitcc153508a747b098eb212d54273b9601aff98300 (patch)
tree0012004ef777acb041508f4c3f748e11c5dd5776 /net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
parentUpdated version of powertweak. diff pulled from cvs on 10/29/2002. (diff)
downloadgentoo-2-cc153508a747b098eb212d54273b9601aff98300.tar.gz
gentoo-2-cc153508a747b098eb212d54273b9601aff98300.tar.bz2
gentoo-2-cc153508a747b098eb212d54273b9601aff98300.zip
Now inherits the gcc eclass and adds fixes appropriately for gcc3 or
gcc2 users.
Diffstat (limited to 'net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild')
-rw-r--r--net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild b/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
index 8d36d74126c5..45b56f5b7f0a 100644
--- a/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
+++ b/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild,v 1.9 2002/10/04 21:22:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/vmailmgr-0.96.9-r1.ebuild,v 1.10 2002/10/29 19:38:20 raker Exp $
S=${WORKDIR}/${P}
@@ -17,9 +17,12 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+inherit gcc
+
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd ${S}
patch -p1 < ${FILESDIR}/${P}-gentoo-r1.diff || die
}
@@ -27,7 +30,14 @@ src_unpack() {
src_compile() {
export CXX=g++
- export LIBS="-lcrypt -lsupc++"
+
+ if [ "`gcc-major-version`" = "3" ]; then
+ export LIBS="-lcrypt -lsupc++"
+ fi
+
+ if [ "`gcc-major-version`" = "2" ]; then
+ export LIBS="-lcrypt"
+ fi
econf || die "./configure failed"