summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-21 18:28:43 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-21 18:28:43 +0000
commit08c1c174eaa964127684e94ff8c5999858b50f53 (patch)
treeb35a5af691b7ba1c442bfb2fba8ee70186787f2b /net-mail
parentVersion bumped. (diff)
downloadgentoo-2-08c1c174eaa964127684e94ff8c5999858b50f53.tar.gz
gentoo-2-08c1c174eaa964127684e94ff8c5999858b50f53.tar.bz2
gentoo-2-08c1c174eaa964127684e94ff8c5999858b50f53.zip
Version bumped.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/ChangeLog7
-rw-r--r--net-mail/fetchmail/Manifest4
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.5.ebuild88
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.2.51
4 files changed, 97 insertions, 3 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 6729177a49ed..0abf51751f84 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.35 2003/09/03 20:44:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.36 2003/10/21 18:28:38 mholzer Exp $
+
+*fetchmail-6.2.5 (22 Oct 2003)
+
+ 22 Oct 2003; Martin Holzer <mholzer@gentoo.org> fetchmail-6.2.5.ebuild:
+ Version bumped.
03 Sep 2003; Aron Griffis <agriffis@gentoo.org> fetchmail-6.2.3.ebuild,
fetchmail-6.2.4.ebuild:
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index f41e3ccfa783..d177a85c09aa 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,11 +1,11 @@
-MD5 ce964548767371d7a9d3865655b0b225 ChangeLog 5988
+MD5 f1b5ec5267423645e47ba7fdf7fba5e9 ChangeLog 6112
MD5 a39c0dfa769bcba7c7a8676ee68689eb fetchmail-5.9.14.ebuild 1929
MD5 9ea407d1e774ec1451772d95366e7d58 fetchmail-6.2.1-r1.ebuild 1785
MD5 bff1d98f24218a2640d5a78339e4fd6f fetchmail-6.2.2-r2.ebuild 2051
MD5 a8b93a340888daa17f543c753c5d0092 fetchmail-6.2.3.ebuild 1969
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 7a30d799878ecfc4318479e0a7041c43 fetchmail-6.2.4.ebuild 2151
-MD5 7a30d799878ecfc4318479e0a7041c43 fetchmail-6.2.5.ebuild 2151
+MD5 2571bea02d4d8147fb8d143322486351 fetchmail-6.2.5.ebuild 2142
MD5 f6bb533591550f2f5978892a3e0a6fc6 files/conf.d-fetchmail 359
MD5 1dd80e46bd5b02949ba0686086a37570 files/configure-5.9.14.diff 2046
MD5 83f3d182af36573e8d7264ee440445ee files/digest-fetchmail-5.9.14 68
diff --git a/net-mail/fetchmail/fetchmail-6.2.5.ebuild b/net-mail/fetchmail/fetchmail-6.2.5.ebuild
new file mode 100644
index 000000000000..b7fbaa5093a9
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.2.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.5.ebuild,v 1.1 2003/10/21 18:28:38 mholzer Exp $
+
+IUSE="ssl nls ipv6 kerberos krb4"
+
+inherit eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.catb.org/~esr/fetchmail/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~x86 -alpha"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/kth-krb )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-6.2.0-gentoo.diff || die
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl"
+ use nls || myconf="${myconf} --disable-nls"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ use kerberos && myconf="${myconf} --with-gssapi --with-kerberos5"
+ use krb4 && myconf="${myconf} --with-kerberos"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.d-fetchmail fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+ einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+ einfo "the polling delay used by the fetchmail init script."
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.2.5 b/net-mail/fetchmail/files/digest-fetchmail-6.2.5
new file mode 100644
index 000000000000..11752ef97731
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.2.5
@@ -0,0 +1 @@
+MD5 9956b30139edaa4f5f77c4d0dbd80225 fetchmail-6.2.5.tar.gz 1257376