summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-09-26 23:32:17 +0000
committerRobert Coie <rac@gentoo.org>2003-09-26 23:32:17 +0000
commit2b20e0fc21e573edf6a8465ff47300f7c36b5e06 (patch)
tree7b7d52a744217df8e5a7f5839b5530670cbf3be5 /net-mail
parentrepoman: Fix leading whitespace (diff)
downloadgentoo-2-2b20e0fc21e573edf6a8465ff47300f7c36b5e06.tar.gz
gentoo-2-2b20e0fc21e573edf6a8465ff47300f7c36b5e06.tar.bz2
gentoo-2-2b20e0fc21e573edf6a8465ff47300f7c36b5e06.zip
add taint patch
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/razor/ChangeLog7
-rw-r--r--net-mail/razor/Manifest9
-rw-r--r--net-mail/razor/files/digest-razor-2.36-r11
-rw-r--r--net-mail/razor/files/razor-taint.patch56
-rw-r--r--net-mail/razor/razor-2.36-r1.ebuild79
5 files changed, 148 insertions, 4 deletions
diff --git a/net-mail/razor/ChangeLog b/net-mail/razor/ChangeLog
index 7c02691ae926..e46504843d77 100644
--- a/net-mail/razor/ChangeLog
+++ b/net-mail/razor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/razor
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/ChangeLog,v 1.8 2003/08/11 10:10:46 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/ChangeLog,v 1.9 2003/09/26 23:32:15 rac Exp $
+
+*razor-2.36-r1 (26 Sep 2003)
+
+ 26 Sep 2003; <rac@gentoo.org> razor-2.36-r1.ebuild, files/razor-taint.patch:
+ Add taint-mode patch from SpamAssassin 2.60 - see bug 29156
*razor-2.36 (11 Aug 2003)
diff --git a/net-mail/razor/Manifest b/net-mail/razor/Manifest
index c3f0aa286afb..f9d01a948886 100644
--- a/net-mail/razor/Manifest
+++ b/net-mail/razor/Manifest
@@ -1,11 +1,14 @@
-MD5 85b0cb3f51ce59110b1ccaee69a0bc7d ChangeLog 1069
+MD5 0b7d0e632bf469220a81431e2a056f56 razor-2.36.ebuild 2674
MD5 b1cdf5d490653ecd10e6fa862f6b82d8 razor-2.12.ebuild 661
MD5 3711bc99b49a9da3020a98a0531845f3 razor-2.14.ebuild 664
+MD5 813816062cf9d1c7d2b333a5e7cef7ca razor-2.36-r1.ebuild 2816
MD5 c3f46137864a383a504ce992658261bd razor-2.20.ebuild 2655
+MD5 ca3bf0695a0ea9a962b88dd732057a6e ChangeLog 1235
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
-MD5 0b7d0e632bf469220a81431e2a056f56 razor-2.36.ebuild 2674
+MD5 d3e9a49fe82b4c304cafaadb03eedb08 files/razor-taint.patch 2125
+MD5 86ce0f71341d41a9cf561083b241c9fb files/digest-razor-2.36-r1 68
MD5 d0a8bbc852b9805e6d3d8538a26e890e files/digest-razor-2.12 68
MD5 1f098b2f3af4b936a9abf9b3ff35f5d9 files/digest-razor-2.14 68
MD5 e384efda6a508c06a7ce0c4b196d2fb9 files/digest-razor-2.20 68
-MD5 cf27167873572ac8be99c5195762d630 files/razor_uninstall.patch 1765
MD5 86ce0f71341d41a9cf561083b241c9fb files/digest-razor-2.36 68
+MD5 cf27167873572ac8be99c5195762d630 files/razor_uninstall.patch 1765
diff --git a/net-mail/razor/files/digest-razor-2.36-r1 b/net-mail/razor/files/digest-razor-2.36-r1
new file mode 100644
index 000000000000..1f6263834c7d
--- /dev/null
+++ b/net-mail/razor/files/digest-razor-2.36-r1
@@ -0,0 +1 @@
+MD5 5deaae3ea2300bf480b6904f8a69a7f1 razor-agents-2.36.tar.gz 78709
diff --git a/net-mail/razor/files/razor-taint.patch b/net-mail/razor/files/razor-taint.patch
new file mode 100644
index 000000000000..da3295a55624
--- /dev/null
+++ b/net-mail/razor/files/razor-taint.patch
@@ -0,0 +1,56 @@
+--- lib/Razor2/Client/Agent.pm~ Tue Nov 19 16:26:05 2002
++++ lib/Razor2/Client/Agent.pm Sun Sep 21 23:20:47 2003
+@@ -981,6 +981,7 @@
+ my @fns;
+ if (opendir D,$self->{razorhome}) {
+ @fns = map "$self->{razorhome}/$_", grep /^server\.[\S]+\.conf$/, readdir D;
++ @fns = map { /^(\S+)$/, $1 } @fns; # untaint
+ closedir D;
+ }
+ foreach (@fns) {
+--- lib/Razor2/Client/Config.pm~ Thu Nov 14 14:47:01 2002
++++ lib/Razor2/Client/Config.pm Sun Sep 21 23:18:52 2003
+@@ -333,9 +333,11 @@
+ if ($fn =~ /^(.*)\/([^\/]+)$/) {
+ my $dir = $1;
+ $fn = readlink $fn;
++ $fn = $1 if $fn =~ /^(\S+)$/; # untaint readlink
+ $fn = "$dir/$fn" unless $fn =~ /^\//;
+ } else {
+ $fn = readlink $fn;
++ $fn = $1 if $fn =~ /^(\S+)$/; # untaint readlink
+ }
+ }
+ }
+@@ -376,13 +378,13 @@
+ chomp;
+ next if /^\s*#/;
+ if ($nothash) {
+- s/^\s+//; s/\s+$//;
++ next unless s/^\s*(.+?)\s*$/$1/; # untaint
+ $conf->{$_} = 7;
+ push @lines, $_;
+ } else {
+ next unless /=/;
+- my ($attribute, $value) = split /\=/, $_, 2;
+- $attribute =~ s/^\s+//; $attribute =~ s/\s+$//;
++ my ($attribute, $value) = /^\s*(.+?)\s*=\s*(.+?)\s*$/; # untaint
++ next unless (defined $attribute && defined $value);
+ $conf->{$attribute} = $self->parse_value($value);
+ }
+ $total++;
+--- lib/Razor2/Client/Core.pm~ Wed Nov 13 12:01:10 2002
++++ lib/Razor2/Client/Core.pm Sun Sep 21 23:20:21 2003
+@@ -218,8 +218,10 @@
+ foreach $rr ($query->answer) {
+ my $pushed = 0;
+ if ($rr->type eq "A") {
+- push @list, $rr->address;
+- $pushed = 1;
++ if ($rr->address =~ m/^(\d+\.\d+\.\d+\.\d+)$/) {
++ push @list, $1;
++ $pushed = 1;
++ }
+ } elsif ($rr->type eq "CNAME") {
+ if ($rr->cname eq 'list.terminator') {
+ pop @list if $pushed;
diff --git a/net-mail/razor/razor-2.36-r1.ebuild b/net-mail/razor/razor-2.36-r1.ebuild
new file mode 100644
index 000000000000..3368aea4d54b
--- /dev/null
+++ b/net-mail/razor/razor-2.36-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/razor-2.36-r1.ebuild,v 1.1 2003/09/26 23:32:16 rac Exp $
+
+inherit perl-module
+
+S="${WORKDIR}/razor-agents-${PV}"
+
+DESCRIPTION="Vipul's Razor is a distributed, collaborative spam detection and filtering network"
+HOMEPAGE="http://razor.sourceforge.net"
+SRC_URI="mirror://sourceforge/razor/razor-agents-${PV}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+IUSE=""
+RDEPEND="dev-lang/perl
+ dev-perl/Net-DNS
+ dev-perl/net-ping
+ dev-perl/Time-HiRes
+ dev-perl/Digest-SHA1
+ dev-perl/URI
+ dev-perl/Digest-Nilsimsa"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch --no-backup-if-mismatch -p0 < ${FILESDIR}/razor-taint.patch
+}
+
+src_install() {
+
+# seems broken in 2.36 (rac)
+# patch -p1 < ${FILESDIR}/razor_uninstall.patch
+
+ perl-module_src_install
+}
+
+pkg_postinst() {
+
+# insures appropriate symlinks have been created
+ /usr/bin/razor-client
+
+einfo "Run 'razor-admin -create' to create a default config file in your"
+einfo "home directory under /home/user/.razor. (Remember to change user to"
+einfo "your username from root before running razor-admin)"
+einfo ""
+einfo "Razor v2 requires reporters to be registered so their reputations can"
+einfo "be computed over time and they can participate in the revocation"
+einfo "mechanism. Registration is done with razor-admin -register. It has to be"
+einfo "manually invoked in either of the following ways:"
+einfo ""
+einfo "To register user foo with 's1kret' as password: "
+einfo ""
+einfo "razor-admin -register -user=foo -pass=s1kr3t"
+einfo ""
+einfo "To register with an email address and have the password assigned:"
+einfo ""
+einfo "razor-admin -register -user=foo@bar.com "
+einfo ""
+einfo "To have both (random) username and password assgined: "
+einfo ""
+einfo "razor-admin -register "
+einfo ""
+einfo "razor-admin -register negotiates a registration with the Nomination Server"
+einfo "and writes the identity information in"
+einfo "/home/user/.razor/identity-username, or /etc/razor/identity-username"
+einfo "when invoked as root."
+einfo ""
+einfo "You can edit razor-agent.conf to change the defaults. Config options"
+einfo "and their values are defined in the razor-agent.conf(5) manpage."
+
+einfo "The next step is to integrate razor-check, razor-report and"
+einfo "razor-revoke in your mail system. If you are running Razor v1, the"
+einfo "change will be transparent, new versions of razor agents will overwrite"
+einfo "the old ones. You would still need to plugin razor-revoke in your MUA,"
+einfo "since it's a new addition in Razor v2. If you are not running Razor v1,"
+einfo "refer to manpages of razor-check(1), razor-report(1), and"
+einfo "razor-revoke(1) for integration instructions."
+}